IoTaWatt and Internet


#1

Does the IoTawatt device require and internet connection to operate? Can it just run on a local WiFi connection not connected to the internet? I realize to get the updates it would need to be but what if it were setup initially connected and updated then installed someplace where no internet connection is available? Maybe connect it annually to a hot spot for the updates?

Thanks,
Jamie


#2

It should work as long as its connected to WiFi. The only caveat would be that it keeps the real-time-clock in sync by accessing a NTP server every hour. The onboard RTC can gain or lose up to two seconds per day, so after a year, it could be off by quite a bit.

I would recommend setting auto-update to NONE so that it doesn’t try to access the auto-update server. Another issue you may have is that the local graph application uses the internet to download large JavaScript files to do the graphing work and other things. So there would need to be an internet connection to retrieve historical data. The configuration app should work OK and allow viewing real-time status and the message log.

No guarantees. You would have to try it.


#3

You can setup a local NTP server (on a RPi even) that is backed by a GPS receiver.

Your computer that is accessing the web UI of IoTaWatt will need access to the internet to display the graph UI, if not more. But if you send the data to a local instance of Influxdb and Grafana you will have access to the data that way.


#4

Those are great suggestions. The only fly in the ointment is that I would need to provide a way to specify an alternate NTP server. The next release is going to switch over from using pool.ntp.org to using time.google.com. It would be easy to add an alternate (or four) NTP name to the config file. There have been other issues where that would have been helpful.

It might also be possible, albeit slower, to provide backups to the CDN files via the IoTaWatt web server directly. I need to figure out how to do that in the web apps.


#5

Hard to believe but where I’m located there are a lot of households without internet. (just got indoor plumbing a couple years ago) lol. Seriously tho they are using there cell phones for the internet. Anyway Not tested yet but I have a Rpi setup as a WiFi router with DHCP. I’ve installed the TIG stack on it. Plan is to install the IoTaWatt and Rpi as a package deal. All the data will be viewed with a basic Grafana dashboard. I have Pivpn installed on it as well for those who do have internet to view from abroad. Those with internet I would set the Rpi to be an AP hard wired to the main router and solve any distance issues with the current WiFi. Guess I’ll wait until I can change the NTP server as mentioned to solve the clock issue. Thanks!


#6

BTW for the test RPi I have the above set up along with Pi-hole installed serving 3 clients and 1 VPN connection, processor load is at 25 to 30 % and temps are at 65° with heat sink and no fan. RPi’s are amazing.


#7

No plan to do that yet, so I’d suggest you start the IoTaWatt up with an internet connection and then move it to the Rpi AP. The clock creep should not be an issue for some time. You will just get a message every 24 hours saying no time-sync was accomplished, but the time should be pretty good for a few months or possibly more. Your basic Timex, not a Rolex.


#8

Surprising timing, but I actually put in a request on GitHub to have IoTaWatt use the NTP server(s) specified by DHCP just 2 days ago.


#9

I like the idea of getting it through DHCP, I just don’t know if that is available to me through the ESP8266 code that is doing the DHCP handshake. I’ll try and see if there is something obvious. Probably going to end up being something you need to specify.

I hadn’t seen the issue on Github yet. I’ll respond to that when I have had a chance to digest the options.

Thanks.