New Setup - Cannot access IotaWatt - Resolved


#1

I am setting up my IotaWatt for the first time. I was able to connect and configure the wifi, but once I did, I can no longer access the device.

The LED is a solid green and my router is showing it is connected with a valid IP address, but I cannot ping or connect - even directly via IP.

Is there a way to reset the device? I only way I can see to do that requires connectivity…

Thanks…


#2

Sounds like the device is working. You just need to access. Are you sure you are on the same WiFi network, and whatisthedevice type you are using to access?


#3

Yes, I can see it connected on the router (192.168.1.137 ) but i cannot ping or connect to it. I have tried to connect via a phone connected via wireless (same network) and via a computer physically attached to the router on the same network.

I have rebooted the iotawatt and the router and have even seen it pick up a new IP address, but still cannot connect…

Any suggestions to reset the config on the device so I can try again?


#4

That does not appear to be the problem. The fact that it is reestablishing a connection after restart, indicates to me that there is a viable connection. Also, a solid green LED indicates that the IoTaWatt has successfully accessed an internet time server, so there is bi-directional communication.

Given what you describe, it should respond to a ping. What was your order number?


#5

The Order #: 20190013.


#6

That’s not one of my order numbers. Where did you order it from?


#7

Sorry. That was the invoice number. Order #804.


#8

Got it, thanks. I could have you take the thing apart and extract the log, and do other experiments to try to diagnose this, but you are close and it would be faster to just send the base unit back to me. I’ll analyse the log and determine what happened. The address is the return address on your label.

I’ve not seen an ESP8266 that can talk on the internet but doesn’t respond to a ping. If I can validate that, I’ll replace it. My suspicion is that it’s something else that is stopping your communications with it.


#9

I really don’t mind… I read in another post that there is an SD card. If the logs are there, let me know what to grab and I can send them along.


#10

The log is at /Iotawatt/iotamsgs.txt on the SDcard. If you want to open it up and post a copy of that, it may be helpful.

But my issue is that you cannot ping the device when it appears to be communicating with the router. With the log I can verify that it is communicating on the internet, but if so, I can’t tell you why you are unable to ping it. I keep going back to some kind of communications problem on the lan. There’s lot of different technology in the routers provided by cable companies and in the multiple node whole house systems being sold. I don’t have the resources to keep up with that. All I can do is verify that it does ping when communications reach it.


#11

That’s what I am thinking too. The setup isn’t fancy, and its not a cable modem/combo. The router is an Asus AC3100. This log shows 2 different IP addresses. As part of the troubleshooting, I did do a complete reset of the wifi and device, which was when it came back as 192.168.1.137.

The other log files (histlog.log and iotalog.log), contain characters such as:
ôõÖ\ ë:£Ò¢?p$îñ=¨ÿ?

They do have a recent time stamp for today, so they are being written to. For context, the size of each is: histlog.log - 317KB and iotalog.log - 3.8MB

Also, just in looking at the sd card, the only file that appears to be an executable is /download/02_04_00.BIN. Everything else is .log, .txt, .htm, or .js. I just wanted to make sure that is what you expect to see.

Trace: 203:57[176], 213:78[238], 245:6[35], 143:129[41], 186:208[99], 87:12[150], 123:31[165], 17:123[117], 142:140[58], 235:114[94], 221:62[226], 123:98[54], 152:10[177], 44:149[31], 71:69[192], 75:111[141], 203:42[195], 119:214[124], 154:113[93], 34:120[158], 40:1[66], 188:70[153], 142:228[109], 77:61[89], 144:184[131], 163:24[251], 41:126[93], 139:47[66], 204:226[192], 2:142[162], 187:166[248], 183:83[222]
ESP8266 ChipID: 2528364
IoTaWatt 4.x, Firmware version 02_04_00
SPIFFS mounted.
Local time zone: +0:00
device name: IotaWatt
Connecting with WiFiManager.

** Restart **

SD initialized.
Real Time Clock not initialized.
Reset reason: Power on
Trace: 201:49[48], 221:78[238], 245:6[51], 11:129[169], 250:208[99], 87:12[150], 123:31[37], 17:125[117], 206:140[58], 239:82[94], 221:62[226], 115:114[54], 152:10[177], 44:149[15], 7:69[192], 75:109[141], 203:42[143], 119:214[124], 218:113[93], 34:120[94], 40:5[66], 184:230[153], 142:164[125], 73:29[89], 208:184[131], 163:24[251], 41:126[221], 139:47[66], 68:97[192], 2:138[162], 155:166[216], 183:83[254]
ESP8266 ChipID: 2528364
IoTaWatt 4.x, Firmware version 02_04_00
SPIFFS mounted.
Local time zone: +0:00
device name: IotaWatt
Connecting with WiFiManager.
RTC not running, waiting for WiFi.

** Restart **

SD initialized.
Real Time Clock not initialized.
Reset reason: Power on
Trace: 139:49[48], 213:94[238], 247:6[35], 15:129[169], 186:208[99], 87:12[150], 123:31[37], 17:123[117], 206:140[122], 235:114[94], 253:62[226], 115:98[54], 152:10[241], 44:149[95], 7:69[192], 75:109[141], 203:43[135], 119:222[125], 138:113[93], 32:120[30], 168:5[66], 184:198[153], 142:228[125], 93:61[89], 208:184[131], 163:24[251], 41:126[149], 139:47[66], 64:97[192], 2:142[162], 155:166[216], 151:83[222]
ESP8266 ChipID: 2528364
IoTaWatt 4.x, Firmware version 02_04_00
SPIFFS mounted.
Local time zone: +0:00
device name: IotaWatt
Connecting with WiFiManager.
RTC not running, waiting for WiFi.
MDNS responder started for hostname IotaWatt
LLMNR responder started for hostname IotaWatt
HTTP server started
WiFi connected. SSID=KoopNET, IP=192.168.1.138, channel=11, RSSI -41db
timeSync: service started.
statService: started.
Updater: service started. Auto-update class is ALPHA
5/11/19 16:18:01z timeSync: RTC initalized to NTP time
5/11/19 16:18:01z dataLog: service started.
5/11/19 16:18:01z dataLog: New current log created.
5/11/19 16:18:03z Updater: Auto-update is current for class ALPHA.
5/11/19 16:20:01z historyLog: service started.
5/11/19 16:20:01z historyLog: first entry 05/11/19 16:19:00
5/11/19 16:45:43z WiFi disconnected.
5/11/19 16:48:03z WiFi connected. SSID=KoopNET, IP=192.168.1.137, channel=1, RSSI -34db


#12

There is nothing unusual in your description of the various files on the SD.

The message log that is posted above is pretty much what I expected as well. The IoTaWatt is definitely connected to the WiFi network KoopNET, and it did recognize the new IP assigned when the WiFi was disconnected yesterday around noon (14:48 UTC). Since connecting it has communicated over the internet with an internet time server to set date/time, and has connected to the IoTaWatt server to check that the firmware is current (it is).

So communication is up and running normally. I might pursue that the .htm files needed for the web server to serve the config utility are present, but you say you cannot ping the IoTaWatt, so that would appear to be the fundamental problem indicating it is a lan issue where you cannot communicate with the IoTaWatt IP address. There is nothing I can do to compel the IoTaWatt to respond to requests that it does not receive.

If we’re to bring down WiFi network KoopNET, on restart the IoTaWatt will re-enter AP mode for three minutes. At that time you can connect it to a different WiFi network. You could also move it to a new location with a different WiFi network and connect to that in the same way. If your lan is inhibiting communications, perhaps it will work elsewhere. At least you will know for certain it was a lan problem.

Beyond that, I can’t be of much help. I don’t have the expertise or time to diagnose lan issues. If you can’t resolve this, you can return it as incompatible with your lan environment.


#13

2 questions:

  1. Just to clarify, if iotawatt cannot find the currently defined network upon startup, I will be able to connect to it for 3 minutes the same way as when I initially configured it?
  2. Is there any way to look at the lan configuration on iotawatt - either in some config file or otherwise?

I haven’t had an issue like this with any other devices, so it would be helpful to validate the full network configuration on the device.


#14

Correct.

Above you see the SSID, the IP obtained via DHCP, the channel assigned, and the RSSI (which is excellent).


#15

Yes, I saw those items in the log. What I was looking for were additional configuration items, such as netmask, default router, name servers, etc. The other items that get passed via DHCP. Based on your response, I assume the answer is no, they are not available. After some additional troubleshooting, I learned it was on the network and visible via MAC address, but responses were not coming back from the device. It definitely appreared as though it was not recognizing it was on the same subnet as everything else.

However, I can now access the web server. I set a static IP in the address table with a much lower IP and then I reset the wireless config (turned off the router and re did the configuration to the wireless - but same network). I have no idea why that worked, but I can now ping and connect normally. I can only assume that it only pulled down a partial config initially or something, and manually setting the IP on the router forced it to re-pull all the parameters.

Like I said, I don’t fully understand why it’s working now but the important thing is it is.

Thanks for your help.


#16

Getting connected is the hardest part. You should have no trouble setting up the config. Good Luck.