Enphase Solar Input - Nighttime power consumption

Hi, new iotawatt user, I’ve just installed my device over the weekend - https://photos.app.goo.gl/wVhzcsgiitcyUiHj9

Once my Enphase solar system stops producing for the day, its starts showing 13-17W of consumption - but on the Solar input, whether or not this is the Envoy and a combination of the x26 micros i’m not sure. The same consumption also shows up the Envoy installer portal.
We are talking small numbers here but it is still throwing out the solar production numbers.

Anyone know of a way this can be stopped?

Some inverters consume standby power when not producing power. The default setting for the input is to automatically convert negative power values to positive. This is what appears to be happening here:

image

If this is a problem, you can check the “allow negative power values” box for the input. Then where you use the value in a script, use the max function to effectively suppress negative values:\

(solar max 0)

Understand that max and min are binary functions and result in the larger and smaller of the two operands. So if solar is -14, the function evaluates to -14 max 0 = 0.

If you are inclined to also measure the standby (negative) consumption of the inverters, you can use the min function:

(solar min 0)

to develop the negative value, and

((solar min 0) abs)

if you want it as a positive number.