Error updating PVoutput

After getting my system fixed over the weekend (thank you) I now wanted to update my consumption numbers. I thought I could go change my pvoutput equation to 2x the two inputs that were configured incorrectly. I could then re-load my PVoutput data to get it fixed. After the reload, I would set my PVoutput equation back to what it should be today. I was hoping to have good data in PVoutputs.

I tried that, but I just get:
11/23/20 09:38:30 PVoutput: Unrecognized HTTP completion, upload Bad request 400: Invalid data format [20

so I gave up on that idea and just changed my PVoutput equation to be what it should be. Upmain_1+Upmain_2+Downmain_1+Downmain_2. I then set my history reload to be 11/21 as that is when I got things fixed. I then clicked “stop” the update, but that didn’t seem to do anything. I waited, tried again, the restarted. When it came back up it did say it was uploading from that date, but I get the same message in the log file now as well. Ideas? This used to work without any issue.

It did upload a bit of data from today between the reboot and me telling it to reload history. So some part of it work.

I just restarted and stopped history upload and it is currently uploading data. Just seems the history reload is not working for me.


Need to see the PVoutput setup and the message log.

Message log has hundreds of these:
11/23/20 09:07:10 PVoutput: System Peart, interval 5, donator mode
11/23/20 09:07:10 PVoutput: Reload status beginning 04/07/20 00:05:00
11/23/20 09:07:17 PVoutput: Unrecognized HTTP completion, upload Bad request 400: Invalid data format [20


This is working as long as I don’t try to reload history. I did move my CTs so that UpMain_1 and UpMain_2 no longer shared with Solar, so I don’t need to subtract that out.

The consumption equation I tried to change to, to “fix” my data was:
(DownMain_1 + DownMain_2 + (UpMain_1 + UpMain_2) * 2) - Solar

What I had run since the beginning was:
DownMain_1 + DownMain_2 + UpMain_1 + UpMain_2 - Solar

And it worked along with reloading history.



The log says you were trying to update from 04/07/20. PVoutput only accepts historical data for the past 14 days, and 90 days if donator (you are). So the earliest I would expect to work is 08/25/20.

But you say it doesn’t work reloading from 11/21/20, so I’d like to see the log entries for that.


Last I saw of your configuration, the barn would be excluded.

It looks like you are getting generation data from your inverter. That’s OK, but that can complicate the update process. PVoutput has rules for updating from multiple sources. I haven’t worked on this recently enough to remember the nuances, but I suspect that has something to do with it. PVoutput computes import and export using generation and consumption. When those come from two separate transactions, there may be some sequencing issues.

Most folks just upload generation and voltage from the IoTaWatt along with the consumption.

It successfully uploaded all my consumption today. So I just hit reload history from the 21st.

11/23/20 16:53:45 PVoutput: System Peart, interval 5, donator mode
11/23/20 16:53:45 PVoutput: Reload status beginning 11/21/20 00:05:00
11/23/20 16:53:53 PVoutput: Unrecognized HTTP completion, upload Bad request 400: Invalid data format [20


I’m pretty sure it has something to do with the inverter updating live data. Looking at previous days, it only sends live data when there is inverter output. IoTaWatt posts data for the whole 24 hours - 288 entries. So I don’t know what happens when you try to post where there was no live record before.

Beginning tomorrow, you will have data posted for the whole day, so on Wednesday, try to reload beginning Tuesday 11/24 and see if that works.

In the meantime, you are a donator, so you can upload six additional series. You can upload your IoTaWatt’s solar measurements to one of those additional series and then in a few days compare it to the inverter generation data to prove they are the same. Then if that’s the case, I’d recommend stopping the inverter upload and sending the IoTaWatt solar as generation.

When I changed the reload range to just yesterday, the first complete 24hour period after my changes and it uploaded fine. You can now see that I have data for yesterday and all of today. This AMs data didn’t get uploaded because it was erroring out trying to reload data. I figure that out this AM and turned it off around the time I posted.

I’ll have to look into how to upload two series and compare them on PVoutput.