Fix clock skew? - resolved

How do I fix clock skew?

In both Graph and Graph+, the Time on the x-axis is 4hrs off.

I have stepped through Setup->Device->Time Zone, then Save. I’ve already Restarted after re-setting the Time Zone.

The graph time looks to be exactly 4hrs shifted forward, but I’ve set my local timezone (-6) so is there a way to force the real time clock on the IotaWatt?

What is your time zone, and does your computer have its timezone set correctly? Are the time stamps in the IoTaWatt message log correct?

nm – this was from new Firefox privacy settings affecting the Graph+ time displayed. [0]

And yes the timestamps in Message Log are correct. All good now.

[0] https://support.mozilla.org/en-US/questions/1191823