Floor function in defining outputs

Howdy Folks.
Just recently installed an IoTaWatt v5 and have that data piping to PVOutput.org (see my install in the “Case Studies” forum). For the “production” value, several times through the night, the IoTaWatt is reporting 1-5W production to PVOutput. That seems well within the margin of error, but curious if there’s a way I could define an output that “if solar_1 < 10; output 0; else output solar_1”. I know I could do something like “(solar_1 - 10) max 0”, but that’d always report 10W less than actual…which probably would be acceptable.
Is there some clever way I could use min/max/abs to get this sort of filtered data?

I used to want to do the same as you. However, I have come to learn that over the time I have had my IoTaWatt that such small (marginal as you said) mounts just do not really add up to much over the period of a day, etc.

I would think if you modified things by creating a filter as you suggest, you may be going the other way with the number. Just my thoughts, but happy to hear how others have handled it.

I don’t believe 5W is anywhere near the margin of error. I bet if you shut down the breaker going to the inverter, you’ll get a pretty solid
zero Watts.

What I believe is going on here is that the inverter draws standby power at night. You can test this by selecting “allow negative values” on the solar CT input. Those nocturnal loads should go negative.

Should that prove to be the case, you can define generation as

Solar_1 max 0

That will zero the negative standby power use.

UPDATE: Deleted an algorithm I posted that was wrong.

I agree with @overeasy if this is specific to the solar. I see anywhere from -5 to -8 watts from the inverter once the sun goes down.

Agreed it isn’t a big deal regardless.
I have the CTs set up just like any other breaker, meaning they display negative wattage during production (therefore I checked the “allow negative” box). I realized later that the convention is to reverse that, so I then selected the “reverse” option instead of physically swapping the CTs. Therefore if the inverters are drawing power, they’d show as negative values now…so I don’t think that’s it.

You might just double check the configuration. Inverters usually draw standby power.

Looking at your panel in the other post, which is the solar? Is it the top right? The reason I ask is that the Ct on that is right next to the main. It would be easy to move it down near the circuit breaker in case the main is causing it.

BTW, if that is the solar circuit, I’m pretty sure the code requires it to be at the bottom of the panel.

Top left is the solar input - and noted on needing to be at the bottom of the panel. I’ll look up the NEC.
I think you figured it out though - the 1-5W usage correlates to when I have other high usage devices running, like the furnace or water heater. Looks like that CT is picking up that from the mains. I’ll move it further away.

As I understand it, the load center is designed to handle 200 Amps on the backplane and overcurrent is protected by the mains. When you add solar at the top, it adds to the maximum allowed by the mains and so the downstream backplane Is subjected to main+solar current. When the breaker is at the bottom, the backplane is subjected to mains-solar.

Yes, that’s how I understand it too. Either I need to move that breaker down, or swap the main breaker so that it plus the solar backfeed doesn’t exceed 120% of the capacity of the backplane. Thanks for the tip.

Just to follow up and close the loop: I extended the solar backfeed lines and now have those feeding into the bottom of the panel. In the process of that I moved the solar CT so it isn’t adjacent to the mains CT, and now the phantom 0-8W reading through the night are gone. Thanks for all the help.

1 Like