Help setting up iotawatt on Emoncms.org

I set up my Iotawatt a few weeks ago but have not been able to get the link to Emoncms to work. Followed the directions in the Iotawatt Docs, but don’t see the input.

Do I have to have an open port thru my firewall to transmitt data to Emoncms? Any help would be appreciated…

Dave C

More Info… The following is from my message log…
9/06/19 22:50:26 EmonService: started. url:80=emoncms.org, node=IotaWatt, interval=10, encrypted
9/06/19 22:50:45 EmonService: get input list failing, code: 302

What is causing Code 302?

302 is a redirect. Along the way, a proxy or server is saying to retry the request with a different URL. If you are trying to use Emoncms.org, then you need to specify:

http://emoncms.org

for the server URL. If you are using your own local instance, then you specify the local IP address.

I’m using the URL exactly as you stated it. The default in the setup dialog box of the Iotawat… No Joy…

Make sure you specify HTTP and not HTTPS as the IoTaWatt will only communicate using HTTP. As @overeasy said, a 302 error message from the Web is a redirect and often from an HTTPS to and HTTP, etc.

Still no Joy… I checked and I’m using HTTP: not HTTPS.

Is there a way to get a log from emoncms or something else to give me more insight. I freely admit, I’m not familiar with this at all, and although I’d like to learn to create these programs myself, I’m a complete neophite at this right now.

Appreciate you guys help.

Dave

Can restart then post

  • setup screen for emoncms (sans write key).
  • message log for entire startup to present subsequent to that restart
    Thanks

SUCCESS! I don’t know what I did since I tried several things. In any case, I have inputs now on Enomcms.org and I’m learning how to create fees, etc.

Thanks for your help.

Dave C

Probably the restart. Had you restarted it before?

In setting up the feeds, be aware that you pay per feed, so you can have as many inputs as you like (they don’t consume disk storage) but only commit to feeds data that you may want to see.