InfluxDB2 uploader not working - resolved

IotaWatt seems to be working, but the uploader for InfluxDB_v2 is not. All of the settings are properly in place and the logfile shows the following (after a restart from the web interface):

** Restart **

SD initialized.
7/27/21 19:14:56z Real Time Clock is running. Unix time 1627413296
7/27/21 19:14:56z Reset reason: Software/System restart
7/27/21 19:14:56z Trace: 29:64, 29:65, 29:63, 29:64, 29:64, 29:65, 29:63, 29:64, 29:64, 29:65, 29:63, 29:64, 29:64, 29:65, 31:1, 1:6[6], 1:1, 1:2[1], 9:0[1], 9:0, 9:1, 8:4, 8:6, 8:8, 8:9, 9:3, 9:5, 9:9, 1:2, 1:3, 10:2, 10:3
7/27/21 19:14:56z ESP8266 ChipID: 16309867
7/27/21 19:14:56z IoTaWatt 5.0, Firmware version 02_06_02
7/27/21 19:14:56z SPIFFS mounted.
7/27/21 14:14:56 Local time zone: -6:00
7/27/21 14:14:56 Using Daylight Saving Time (BST) when in effect.
7/27/21 14:14:56 device name: IotaWatt
7/27/21 14:14:56 HTTP server started
7/27/21 14:14:56 influxDB_v2: Starting, interval:10, url:
7/27/21 14:14:56 timeSync: service started.
7/27/21 14:14:56 statService: started.
7/27/21 14:14:56 dataLog: service started.
7/27/21 14:14:56 dataLog: Last log entry 07/27/21 14:14:50
7/27/21 14:15:01 historyLog: service started.
7/27/21 14:15:01 historyLog: Last log entry 07/27/21 14:14:00
7/27/21 14:15:02 WiFi connected. SSID=SPEEDFORCE, IP=, channel=1, RSSI -80db
7/27/21 14:15:02 MDNS responder started for hostname IotaWatt
7/27/21 14:15:02 LLMNR responder started for hostname IotaWatt
7/27/21 14:15:02 Updater: service started. Auto-update class is MINOR
7/27/21 14:15:03 influxDB_v2: Start posting 06/20/21 01:00:10
7/27/21 14:15:04 Updater: Auto-update is current for class MINOR.

Can you post the influxDB2 setup and your status display please?

This has been the setting since I got the unit and worked without issues. I have other stuff collecting to InfluxDB as well and those restarted and are collecting properly. I use Grafana to test, but also verified that these were not collecting via InfluxDB Data Explorer in their web interface.

Would you expose the “uploaders” tab on the status display?

It’s a snapshot , but I’m guessing that the “Last update” is advancing. At 14:15 it started posting from 6/20/21 and now at 14:58 it’s reporting 6/26 4:08 am. Can you check if you have data from 6/20 to 6/26?

BTW/ What do you mean by “lost power” in the title?

I have data all the way up to 7/27 @6:00 AM (approximately). This morning the power went out in the neighborhood for a few hours.

Data from InfluxDB Data Explorer (bottom is newest):

And, finally… yes, Last update is advancing. Maybe it just re-started all the way back to 6/20 and is going to re-upload all the data? If so - then it will take quite a bit longer.

IoTaWatt doesn’t know that. It started uploading from 6/20/2021 as per the “upload history from”. There is a problem with using the $device variable in the key-values field. It is fixed in 02_06_05 now in BETA, or you can just specify “IotaWatt” in the device tag. The $device variable was causing the last entry query to fail.

If you change the device tag to “IotaWatt” and restart, it should pick up on 7/27.


So I should change the Tag Key = IotaWatt and leave the tag value to $device? Sorry, not great at this part.

Other way around, leave the key “device” and change the value to “IotaWatt”.

ok. that worked. thank you!

1 Like