IotaWatt failed when moved after setup

Hi, I have two IotaWatts and the 2nd one was set-up on bench and then moved to garage DB cupboard. It was running for a while and then dropped off so I went and checked it and it has what looks to be 4 flash code Green-Red-Red-Green but the docs don’t show 4 flash codes? I removed and reseated the card but no change. Its brand new so I’m not sure its the card.

Hi Bruce,

That’s a new code that hasn’t made it to the docs yet. The IoTaWatt cannot Json parse the config.txt file.

Sounds like you have already opened it up, so if you could mount the SD card on a computer and post the config.txt file, I can probably fix it for you. Or if you speak fluent Json, you can use something like Json lint to see where it’s bad and fix it yourself.

Its weird because it was running and stopped. It does ping bu no web. I don’t have an sd card adapter for the micro so I’ll have to get on and then upload it to you.

Sorry about that. It really doesn’t need to be a fatal error because I could still start the web server and allow the Sdcard to be edited to fix the config. It’s the first time I’ve seen this in the field. I’ll be curious to see what the damage is.

Hi @overeasy I got a adapter and opened the config.txt and it was blank. So I copied the other one and updated the values and I’m back online. No idea why it blanked it.

Hi, @overeasy I’m having the exact same issue as Bruce. This occurred around the same time, also on a brand new device. I’m able to implement the same resolution as Bruce, but I don’t have a config file to copy over. Could you send me a default config file?

Just to make sure this is the problem and I post the right file, where and when did you get your IoTaWatt?

I purchased it from the official store (Order # 1138). However, I believe I was able to resolve the issue with the config file by using the one you posted on GitHub (https://github.com/boblemaire/IoTaWatt/blob/master/SD/config.txt). I did change the model listed in the config to match the card that was sent with my device… GitHub posted config model TDC DA-10-09-E6 --> changed to TDC DA-09-10-E6

I had a dull red light, but it changed to dull green. I didn’t configure its connection, nor did I see its Ad-Hoc network appear.

OK, Thanks, got the matchup on the order.
Not sure what you are telling me about the status of the config. I think you might be saying that you have solved the problem?
The correct model for the VT is DA-10-09-E6.
The initial configuration file is:
config.txt (610 Bytes)

This thread described a problem with a damaged config file indicated by the LED sequence GREEN-RED-RED-GREEN.

Yes, my issue was identical. Your config file fixed it. Thanks so much for your very timely assistance!

1 Like