Iotawatt status: inactive

Recently we installed a new iotawatt device on our solar project. It has been showing Inactive on Emoncms. On restarting the device, the light has been blinking red-red-red sequence. Kindly, help me as to what should be the next step in troubleshooting?

Hi @sawayra,

Should be able to figure this out. The blinking red-red-red is a catchall halt indicator that is most common when a bad configuration file is encountered, The other possible cause is a corrupted datalog file.

So to figure this out, first can you provide a little more background and context by answering these questions:

  1. About when did you install the IoTaWatt?
  2. Was it successfully installed and posting to eMoncms?
  3. For about how long?
  4. About when did it stop posting to eMoncms? (plot one of your feed and see where it stops)
  5. If you power cycle the IoTaWatt, does the LED go right to the red-red-red or does anything else happen before then?
  6. Have you ever opened up the IoTaWatt and/or removed the SDcard?

Sorry you’re having this problem. Hardware problems are extremely rare, so should be able to get it going.

Answer 1: The iotawatt was recently installed one month ago on October, 1st 2018.
Answer 2&3 : yes it was installed perfectly and showed the reading on EmonCMS for about 12 hours but after that showing inactive status.
Answer 4: on October 2nd 2018 at about 23:00 pm it stop posting to EmonCMS and still showing inactive status.
Answer 5: on restarting LED blinks red-red-red but the blinking is not in the pattern( not the same interval every time) but just after the power cycle it starts blinking.
Answer 6: No , not yet. We have bought new iotawatt so never do anything with SD card or other internal components.

Thank you.
Looking forward for your reply.

Thanks for that detail. It helps narrow down the exposure to known problems. If you changed the auto-update class to ALPHA or BETA, you would have installed release 02_03_16, which had a few problems with the data log that exhibited similar symptoms.

The way forward involves looking at the contents of the SD card. Since the IoTaWatt is not running, the card would need to be removed and mounted on another computer. If that is something you can do, I can walk you through what needs to be done.

If you do not want to do that, depending on where you bought the unit, we can get it serviced. If you are in North America and want to send it to me, I can take care of it. If you got it from OEM, I can arrange for them to handle it.

So let me know how you want to proceed. If you can handle the removing and modifying the SD card contents, I’ll first want you to post the message log, and depending on what is there, either fix the CONFIG.TXT file or remove damaged datalog files.

Actually I am about 300 km away from my project. So, hopefully at weekend I’ll visit my project. The procedure you have mentioned ( reading the SD card on computer) is what I can do. But the problem is I have no idea how to open the iotaWatt device and how to remove the SD card. Can you please guide me the steps.

Thank you.
Looking forward for your reply.

Sure. Turn the IoTaWatt over and pull out the rubber feet:

Remove the phillips head screws in the holes.

While holding the unit by the side panels, lift off the cover from the end opposite to the USB and AC connections.

The microSD card will be plainly visible. It is fragile, so grasp it between two fingernails and pull it out carefully.

Once you get it mounted in another computer, please copy the /CONFIG.TXT file and the /IOTAWATT/IOTAMSGS.TXT files for further diagnosis in case my guess is wrong.

Now delete the IOTAWATT directory.

Replace the SD card snugly, reassemble, and power up. It should be working.

Depending on your auto update status, it may take up to a minute to update to new the latest release. That’s a good thing because the latest release will produce diagnostics and try to fix this problem if it occurs.

1 Like

Ok. I will do this. Thank you so much for your help. I’ll get back to you if any further information is needed.

Where can i download latest firmware release on my new sdcard?

The ESP8266 firmware doesn’t reside on the SDcard. It is flashed into the ESP8266 ROM, either at manufacture, or later during an auto-update. In both cases, the set of associated files that are loaded to the SD are release specific. So you need to know which version of the firmware you have loaded to the ESP8266 to know what set of files needs to be loaded to the SDcard. This is all handled automatically by the auto-update process.

Given the history to date of this issue, It’s not clear why you want to use a new SDcard. The way we left it was:

That message log would reveal the version of firmware that you have loaded. Also, the basic files on the current SDcard should be OK and would be the correct versions for the firmware release loaded into you ESP8266.

By far the easier way to upgrade your firmware would be to get it running under the existing release and allow the auto-update process to do it. It takes less than a minute.

If you are still intent on loading new files and possibly flashing your ESP8266, the files for the latest release 02_03_18 are available in the “releases” part of the Github site. I’m not going to get into how to flash the ESP8266. There is general information available on the internet for that.

The current release has been virtually trouble free for several weeks since it was rolled out. There are no outstanding problems and not even many questions about it, so it is pretty solid. Once again, if you would like to send it in to be tested and reflashed, I can do that or arrange for the OEM shop to do it if you are in Europe.

Basically the sequence of light blinking had changed to green red red which is the SD card accession issue. Thats why i had queries regarding this.
Moreover now i have figured out that previously seated SD card was corrupted and even my pc couldn’t detect it. So i replaced it by a new sd card but still the problem prevails.
Since it is a new sd card, there is only IOTAMSGS.TXT and no CONFIG.TXT files or other. I deleted the directory as per instructions and tried the startup procedure again but no use. It still shows RED RED RED sequence.

Those files are in the SD directory on Github as in the above response. The log indicates your device is using 02_03_13. If you would prefer, just load these files into the root and when you start it up, it should download the latest release automatically. Good luck.

config.txt (546 Bytes)
tables.txt (2.0 KB)
cnfstyle.css (5.5 KB)
index.htm (89.5 KB)

Thankyou for your assistance. The device is in working condition now. Will get back to you if any issue occurs.

I am also on the team which is trying to solve this issue.
Unfortunately the issue is yet unresolved. Would appreciate your further assistance.

IotaWatt is publishing its SSID just fine and we can connect to it and click on the Info button to see the chip ID etc. However as soon as we click on Configure Wifi button. It crashes; led goes to red color and iotawatt’s ssid disappears and computer is disconnected from iotawatt.
We have also tried to use the No scan option and enter the wifi credentials but iotawatt fails to connect to the wifi ssid.

I have completely deleted the SD card and copied the contents of Github’s SD folder but the issue remains exactly the same.
We have tried a couple of different power adapters but the issue remains the same. Do you think this issue can arise due to low power usb power adapter?
Or either its an ESP8266 hardware or firmware issue (very unlikely isn’t it?).

I have attached the IOTAMSGS.TXT file generated after completely deleting the SD card and copying the files from github.

Once again, thanks for you kind assistance so far. Much appreciated.


I’m not following you here. What team and what yet unresolved issue issue? This thread has been inactive for a month. The last posting was from a user who said his problem was resolved.

The log that you post from your device borders on useless. What happened to the original log? It’s impossible for me to diagnose the state of the unit. There are just too many unknowns. You have wiped the SDcard and the real-time clock has been reset.

My sense is that this began as a simple problem, but has been made impossibly complex by these efforts. The firmware release that is installed is old. I can and do fix problems with IoTaWatt, but those fixes have to be installed to be effective. This unit has not been updated since at least November 1.

All I can do is offer to test and reflash the device if you send it to me. Should you elect this option, you can PM me for a authorization and the shipping address.