Led not lighting up

Like any normal human being, I woke up this morning, got my cup of coffee and when to review my energy usage for the week. Unable to reach the device I went to investigate and the device’s LED was not illuminated. I tried multiple 5v usb supplies all with the same result. In addition I tried the iotawatt’s usb power supply on a usb light and the power supply appears to be working. I took the screws off and looked at the board and everything looks perfect to me. Unplugged, I started testing continuity and noticed that all the pins labeled 3v have continuity to the pins labeled grd. This seems odd to me. Anyway, anything else to try or did my unit just die?

There is some continuity to ground, the question is how much? When power is applied, what is the voltage on the 5V pin and the 3.3V pin? Failure of the power supply is rare. What is the order number?

Thanks for the quick response! Ground and 3.3v pin are almost showing perfect continuity at .1.

I’m unable to find a pin labeled 5v. If I measure the 3.3 v pin it pulses from 0 to only around 100mv. Measuring the led, there is 500mv. I’ve liked this unit so much, I’ve ordered two, but can only find 1 order number in my email 125242. Model W14 v5

Just wanted to say thanks to overeasy. I’m back up and running.

1 Like