New device - no firmware or SD contents

My IoTaWatt arrived today from the US (I’m in Australia and I bought from IoTaWatt Stuff and used UPS for delivery) in record time - thank you! Anyway I tried following the setup routine but the SSID was not available, however the AI-Thinker one was which I think is the default 8266 one? The SD card was also blank. I then followed the instructions to flash firmware and load up the correct SD card contents but all I get now is a solid red LED. I have tried:

  • Different power supplies (USB - one mobile phone, one Raspberry Pi)
  • Reference power supply connected or disconnected (I’m using the Jaycar one)
  • Lower level of firmware (located 02_06_02 and the SD card files for it)
  • Different SD card


  • When I remove the SD card, I get the Green-Red-Red code to say it’s missing
  • After the fresh SD card is inserted, the iotawatt folder and log files are successfully created
  • I’m worried that I may not have matching firmware and SD card contents. Can I have a couple of links to download the latest please?

Anything else I should try? I’m really comfortable flashing firmware and following technical instructions so throw them at me please.

Ok, that didn’t last long. It was an issue with the SD card contents and the firmware I was flashing. Found the latest after a bit of digging at this page : Releases · boblemaire/IoTaWatt · GitHub

Downloaded, copied the SD card again and then flashed : all good!

Sorry to bug you all, but it was strange that I got an empty unit.

1 Like

I appreciate folks who try to solve these things themselves but not so much when I’m finally called in to deal with the train wreck.

These units are flashed with manufacture/diagnostic firmware at the factory, then that firmware is activated before shipping to cause the latest firmware release to be installed. It has happened once before that the second step wasn’t successful and that is possibly what happened. At that point it’s trivial to cause the unit to download and install the latest release. We’re past that point now as the unit has been flashed and I have no idea what the current state is. Had it been successfully flashed with any version of the firmware, you should not be seeing a solid red LED.

The first thing I’d like to do, if possible, is figure out the current status. Do you have a microusb cable that you can use to power the device and run a serial monitor like Putty (115200 baud) to see what comes out when you restart it with the reset button on the nodeMCU?

Crossed in the mail. Not such a mess after all. Glad you worked it out.

Thanks for your quick response and sorry I pulled the trigger so quickly! :slight_smile:

I can’t find any process how to flash? I have a module that shows a soft red continues glow, looks as if there is no activity. I already put in a new SD card, but with or without SD card, the led just doesn’t seem to do antything at all but show the soft red glow.
Could it be that I accidentally pushed the RST or FLASH buttons next to the micro USB power supply? Any idea how to reset the device?

That does not cause any problems.
Is your USB power supply adequate?

USB power supply is working perfectly with my other Iotawatt devices.
I fixed one with SD card issue, but this one does not even start, with or without SD card.