New IoTaWatt Unit green light, red flickers, then nothing


I got my additional IoTaWatt’s yesterday. I was setting up on my wifi during dialysis. The first unit worked as expected and is ready to head outside.

The second unit, I

  • Powered up the unit with (an original IoTaWatt USB power brick)
  • Connected to wifi
  • Configured the unit to the production WIFI network
  • It rebooted
  • I could access the unit over wifi with it’s statically assigned DHCP address
  • I tried to change the name, time zone, daylight saving and the firmware setting to MAJOR
  • It seems like it took, gave reboot warning.
  • Upon reboot, I had a short green, then solid red status light.
  • Rebooted a couple times, no changes. I did not have the References power connected during this process.
  • After getting back to my office, I connected a Reference transformer and now have: New IoTaWatt Unit green light, red flickers, then nothing.

I did try changing to another Official IoTaWatt USB charger and it does the same thing.
I do not have another Reference transformer unless I swap out the one outside in the production monitoring chassis.

I could do that, but I’m curious if there are other options I can/should try first.

I can access the device over wireless all of the sudden, here is the last log block. But still no lights. This device has not been granted internet access yet. But I don’t recall the lights being out on the production units at this point of the configuration process.

To add, after more futzing about, it seems I can’t save any changes. I just change the name, IoTa reboots and the old name it back.

Any help?

SD initialized.
Real Time Clock not running.
Reset reason: Power On
Trace: 241:95[202], 7:212[135], 36:137[29], 63:176[238], 190:10[117], 88:4[79], 125:167[98], 6:109[221], 21:171[8], 96:132[176], 209:70[34], 136:199[49], 123:255[43], 66:112[99], 77:249[238], 185:145[136], 117:90[242], 211:114[219], 188:187[190], 47:122[189], 74:37[237], 181:136[198], 179:55[238], 64:239[210], 218:122[153], 49:161[93], 29:1[153], 82:32[34], 162:8[219], 18:70[100], 130:87[226], 56:243[205]
ESP8266 ID: 15907232, RTC PCF8523 (68)
IoTaWatt 5.0, Firmware version 02_07_05
SPIFFS mounted.
Local time zone: +0:00
device name: IotaWatt
HTTP server started
WiFi connected. SSID=pm, IP=, channel=11, RSSI -70db
MDNS responder started for hostname IotaWatt
LLMNR responder started for hostname IotaWatt
timeSync: service started.
statService: started.
Updater: service started. Auto-update class is MAJOR

Not too clear on what has happened, but a few observations:

If you are putting multiple IoTaWatt on the same WiFi network, you should rename the existing unit before adding a new one. Only one (or none) IotaWatt.local at a time.

IoTaWatt don’t do well without an AC adapter connected. That is fixed in the release now in ALPHA.

The LED can be red for either of two reasons:

  1. The unit is not connected to WiFi
  2. The real-time clock is not running. Requires internet access to access time server.

The log shows the Real Time Clock is not running and the unit is connected to WiFi. So I think you need to disambiguate the names and connect it to the internet to set the clock.

Hi Overeasy,

I found one of my original two IoTaWatt’s was using the original name.
Playing around with the names for a couple hours this morning, I think I found some kind of bug, not positive.

I’m not very familiar with these IoT things or their file systems, but it acts like the action after clicking the save button on the " Configure IoTaWatt Device" page is that the saveConfig may return success, but the contents of the write have not been sync’d to the SD card before the IoTaWatt’s power cycles. Just a guess.

At this point, all 4 Units have different names and appear to be working. (On the bench here they have 1 long red light, then the light is off for the same amount of time.)

Reviving this old thread to report in on the insanity.

After a couple weeks of inconsistent behavior, it finally dawned on me the randomish problem wasn’t really random, it followed a certain USB cable. Since replacing the cable, I’ve had zero issues with my production IoTaWatts.

Now the month to sort out the lack of labeling and seeming random placing of outlets and lights on circuits that make no sense to me it another story.

1 Like