Panic modus red-red-red blinking LEDS

Try to configure my second Iotawatt.
Wifi connected. --> green LED lighting -> Input configuration. -> Status and graph worked locally.

Neg. values allowed was on and derived three Phase Support.
VT on Phase A
Try to find the right direction out for CT´s as some values where negativ -> when i see that values in Status no longer updated.

USB-Cable disconnected and reconnected.
Short green light and then red-red-red sequence.

Is there a reset or how can i go back to accesspoint Modus.

There’s no reset (wish there was a way…) but this is most likely a problem with the config file. It could be missing, or damaged, or improper Json.

If you can start it with a USB cable connected to a computer with a terminal emulator like putty (115200 baud), you may get a diagnostic message.

Another approach would be to power down the IoTaWatt, remove the SDcard, and mount it in a computer. Look for config.txt in the root directory. If it’s not there, that’s the problem. If it’s there, it could be invalid or corrupted. You can post it here and I can look at it.

The other thing you can do is clean the SDcard and copy the contents of directory SD from the github git.

Maybe try do download

burn with Etcher a new SD and make new test as fast solution.

I need the unit fast back online as i try to monitor heatpump and houseconsumption in 3 phase environment and we have at the moment the coldest days this winter (-12 degree)

Afterwards i will try to readout the diognostic via putty from the old SD card.
Thanks for the advice.

Never thought that it could be fixed as easy.
Downloaded SD Folder on to my windows PC.
Put in new SD card -> Copy files on SD
Change SD card and voila

red-green-green appears which means Accesspoin mode

Thanks great job

1 Like

How must the SD card be formatted correctly? I try to use a new SD card, but always get the red-red-red sequence. The following messages are shown via the serial port:

SD initialized.
6/23/18 14:57:15z Real Time Clock is running. Unix time 1529765835 
6/23/18 14:57:15z Version 02_03_08
6/23/18 14:57:15z Reset reason: External System
6/23/18 14:57:15z Trace:  15:1, 15:0, 15:1, 15:1, 15:0, 15:1, 15:1, 15:0, 15:1, 15:1, 15:0, 15:1, 15:1, 15:0, 15:1, 11:7, 11:8, 16:0, 11:8, 11:9, 1:1, 9:0, 8:4, 8:6, 8:8, 8:4, 8:6, 8:8, 1:2, 1:3, 1:4, 1:5
6/23/18 14:57:15z ESP8266 ChipID: 2329763
6/23/18 14:57:15z Local time zone: 0
6/23/18 14:57:15z device name: IotaWatt, version: 3
6/23/18 14:57:16z MDNS responder started
6/23/18 14:57:16z You can now connect to http://IotaWatt.local
6/23/18 14:57:16z HTTP server started
6/23/18 14:57:16z dataLog: service started.
mkdir failed: /IotaWatt
6/23/18 14:57:16z dataLog: Log file open failed. 2
6/23/18 14:57:16z Program halted.

I used the following tool to format the new card:

I copied the files at to the top level of the SD card.

Is there anything else to consider?

UPDATE Solved, formatting with FAT16 was the solution. Mac users have a look here:

Just got in Elias, glad you solved this. I typically end up with FAT32 using the windows format utility, which seems to work fine. FAT32 doubles the maximum file size from 2GB to 4GB, but IotaWatt doesn’t use files larger than 2GB anyway.

Copying the files from the Github master is the way to go, but understand those are for the latest firmware release. If you have an earlier release, you should use the root files from that release (available in the git release .zip file. Soon I’ll be adding the capability to load a specific release (as opposed to the current release for your auto-update class). That will insure that the firmware and SD files match.

1 Like