Setup trouble - Captive page not loading - resolved

I’m just unpacking and attempting to install IoTaWatt today. No trouble connecting to the SSID, but after I do, the “captive page” does not automatically load (attempted on Safari on iPhone and Safari and Chrome on Mac OS 10.11.6).

The Quick Start Guide suggests to navigate to, but that doesn’t load either.

What is the SSID that you are connecting to?

It’s iota188379


Does the WiFi that you are connecting to have any kind of logon like you get in a hotel?
Never mind on that, I’m ahead of myself. You don’t get to the captive portal so never select a WiFi network.

So to be clear, you select the iota188379 network on your iPhone and it connects, showing that network above as the connected network, and remains connected. But you don’t get the captive portal?

Correct. I select the iota188379 network on my iPhone, type in the password, and it connects (and stays connected)…but the captive portal doesn’t appear.

And what is the LED on the IoTaWatt doing?

LED is Green-Red-Red

GGR means the SDcard would not initialize. I’m puzzled that you even get a WiFi AP. Can you restart the iotawatt with a power cycle and verify that?

Yes. Tried powering off/on earlier and again now…still the same result.

So let’s take it step by step. Power down and up, and without attempting to connect, what is the LED sequence?

OK. It’s Green-Red-Red

Sorry, had to step out. Five minutes after it’s GRR, without doing anything, does it change?

Without doing anything for 5 minutes, it’s still Green-Red-Red

OK, I can’t explain why you are getting an AP to connect, but the LED is reporting a problem with the SD card. If you are comfortable with opening the it up, there are four screws under the rubber pads which just pull out. Remove the screws and open it up. The SDcard is in the back of the board. You can try removing it and reinserting. Then try to start it again. Careful to never remove or insert the SD while the device is powered up.

If the problem persists and you have a computer with a miscrSD card reader or an adapter, try mounting the card and see if you can read the directory.

If you are not comfortable with any of this, you can contact OEM and return it for them to sort it out.

That did it. I removed the SD card and re-inserted. Now I get a Red-Green-Green LED and the captive page loads when I connect to the IotaWatt network.

Thanks for your help!