Solid Green Light- emoncms feeds inactive

I purchased my IoTaWatt last year and was successful in getting things set up with emoncms. Things this past 3-4 months have been crazy with travel. I recently noticed the light is continuously green but there is no data logging to emoncmy as of September 17th, 2018 (3 months ago).

I have tried to connect to the device via http://iotawatt.local/ with no luck. I keep getting the error: iotawatt.local ’s server IP address could not be found. How can I connect to the device to ensure it is reading data.

My power system is in Florida, 2 phase power (i think). I am trying to connect to the device using a windows machine.

Have you paid the bill?

If you know how to access your WiFi router interface, you can look up the IP address there and connect using that (substitute your device IP address).

How did you connect before this problem? We don’t know what version of software you have on the IoTaWatt, so there are a few other things you can do:

  • Install Bonjour on you windows machine.
  • Try different browsers. I have pretty good luck with Chrome.
  • Try an ios device (iPhone, iPad), they always work.

It seems at least part of the issue was WiFi extenders. I unplugged the extenders and device. When I plugged back in iotawatt, it signaled (red-grew-green) that it could not connect to the internet. From there I was able to connect to device and connect the device to my WiFi. I was also able to connect to my WiFi router to locate the IP address for iotawatt. My issue now is that I can seem to connect to iotawatt via web browser to work through configuration (iotawatt.local or IP address). Always seems to time out and does not seem to matter if I use different browsers or Mac devices (iPad, iPhone). suggestions?

So what is the status of the LED now, is it uploading history to emoncms (check emoncms inputs screen and see if values are changing periodically).

Are you sure your devices are on the same network as the IoTaWatt?
Can you ping the IP address?

The light is solid green on Iotwatt. I logged into my router and identified the IP address. My PC laptop (and ipad) are on the same wifi network, could not log into iotawatt via my browsers (chrome, firefox, explorer) using either method: iotawatt.local/ and or the IP address http://IP. I tried my iphone/ipad and all timed out. Thoughts?

Through my browser, i logged into my router and was able to ping:

PING ( 56 data bytes

64 bytes from seq=0 ttl=255 time=51.265 ms

64 bytes from seq=1 ttl=255 time=74.247 ms

64 bytes from seq=2 ttl=255 time=103.120 ms

64 bytes from seq=3 ttl=255 time=120.080 ms

— ping statistics —

4 packets transmitted, 4 packets received, 0% packet loss

round-trip min/avg/max = 51.265/87.178/120.080 ms

looking through my device names, perhaps the device is not connecting to the wifi. what is the default device name? I am assuming this is the name of the iotawatt (ESP_2384F3).

[From Bob Lemaire]

Usually when a device isn’t connected to WiFi, the LED is red. In your case, it has been months since you have accessed it, and so it could be on an old release, and there are several problems that have been fixed that could be at play here. I just don’t know.

Maybe the best way forward would be for you to shut down the IoTaWatt, open it up, and mail the SDcard to me. I could look at the logs, fix whatever is found, and set it up to update your device to the latest release when you restart it. That would preserve whatever data you have in your datalogs.

Great. I will extract SSD card and send to you. Can you private message me your address?

1 Like