IotaWatt not posting to EmonCMS Server


#1

Hi all
I’m having an issue with posting to my EmonCMS server, for some reason it isnt…
Below is screenshot of settings…
Also is there a way to factory default the unit to start again?

Kind Regards
Dave




#2

@Dave, A little more info would also be helpful. Is this a local EmonCMS install or the hosted version on the OpenEnergy site? I do know that a few others that had a simular issue had problems with SSL (HTTPS) where the IoTaWatt only does HTTP for posting. Did it ever work as the image shows that it seems to have posted or tried on Feb 24th based on the running image you provided. Just curios if you can give us any more info on what may have changed and your setup to attempt to allow the group here to assist you better.


#3

FJust responded to what looks like essentially the same thing yesterday over on the OEM forum. What makes you believe that IoStaWatt is not posting?

It looks like the new node was created and IoTaWatt started uploading history from Feb 1. After about 9 minutes it restarted, probably because the system name was changed to Dereham. The screenshots shown are mixed from before and after that restart, but the status display is from after and indicates that the EmonCMS service is running and had uploaded history through Feb 24. I suspect that if you haven’t stopped it, it is nearly caught up by now.

Your WiFi signalis poor, so that is an issue that could effect bulk upload speed. Nevertheless, it does take awhile to upload history. You can watch the progress in that status display. Emoncms will show the inputs and feeds as INACTIVE until it gets within a few days of the present, but the values will be changing as the history is posted.

You have more than a year of history in the IoTaWatt, so I don’t know why you would want to reset it. However if you do want to clean the history, you can enter the following command in your browser;

http://192.168.197.134/command?deletelog=both

This will clear both logs and restart the IoTaWatt. This should only be used if the IoTaWatt is redeployed with a new configuration or if recommended by me because of the rare case of a damaged log.

UPDATE looking more closely at the log information, and @quella is right that there isn’t a lot to go on, but there are probably some big holes in the datalog when it was not running. There is a discrepancy in the history log that indicates either it was just restarted after a long dormant period, or it has a damaged log, or both. A more recent status display. And message log would help to diagnose that. If the history data from the last year isn’t useful, then go ahead and reset the logs.


#4

Thankyou both for your help.
I had bought a unit to log the supply details of a NHS hospital that we look after, the generator had failed and I wanted to confirm the correct sizing of the new generator.
TBH I had it at the original site for two months posting data flawlessly via a mobile WiFi device as it was in the corner of the remote site, I had disconnected it and then took it to a different hospital as the trust wanted further data to assist in the long term demobilisation plans. I changed the SSID to the trust AP, deleted inputs and outputs. I was having weird things happening and looking at my locally hosted EmonCMS it would suddenly say last update 24 mins ago from the IotaWatt. I also saw things like node not yet created, I also got HTTP error code 14.
I have the unit onsite but I also have a spare working one that I can swap it for if you would like me to bring it back to dissect the data on it? I know the hardware wouldn’t support it but I’d love to have OpenVPN on it for secure remote access as I cant port forward in this corporate environment.

Kind Regards
Dave


#5

Deleting the datalogs should put you back to square one with EmonCMS. Sounds like this unit is just something you have in your toolbox and each new deployment is distinct, with the history being recorded in various instances of Emoncms.

You can port forward to the IoTaWatt and get a little security with the password feature. If you have a VPN that connects you to the LAN, you should be able to access the IoTaWatt using the IP address. Would be best to make the DHCP assignment permanent via the router settings.


#6

Thanks Bob, I’ll swap the unit over and try again.
The network is a corporate environment and I have no control over or indeed able to create VPN’s or router settings, also as its a NHS network things are locked down for obvious reasons.
The reason for mentioning the VPN is that you may take that into consideration when further developing the unit and its hardware capabilities.

Kind Regards
Dave