Wifi problems mesh router

Thanks. Ordinarily my inner tinkerer would try this but with a WFH wife I really don’t want to screw around with the network too often. It’s working and seems stable so I’ll leave it that way for now.

There is nothing I can find in the router’s admin set up which tells me information such as this or what channel an extender is using. It’s like they have decided to obfuscate such things.

I think so. A network overhaul with better equipment is on my home improvement hit list.

IotaWatt is coming up to four days with a stable connection, so that’s a good sign.

As I mentioned in my other thread, after previous failures to load the Home Assistant integration, it successfully loaded yesterday using this IP address. I can only guess these things were related.

I now have the data populating my HA dashboards. I’ll wait a while for confidence with system stability before I use the entities in automations (mostly load management stuff).

Any updates on this one @wattmatters ?? Been a week or so now - how has it been operating with the AP disabled


Hi Craig

It’s been reasonably stable, still occasionally drops onto that IP= mode for while but eventually rejoins to its “proper” local IP address IP= Sometimes it swaps between channels.

I’m assuming the Telstra extender isn’t the best but for now is working. I’ve had a bit much else going on to focus on that issue.

I’m still trying to get data cabling people here. It’s ridiculous. Data comms people here seem to be the worst communicators!

But ultimately I need to ditch the Telstra kit and put something decent in.


System of late has mostly been OK but still drops out at fairly regular intervals. It’s having a particularly bad connection day today. Dropped out at 7:30 this morning and refuses to reestablish connection sitting instead on IP=, which means it can’t find it’s local (static) assigned IP address and I don’t know how to get it back online.

It has perfectly fine signal strength. I know it’s not the IoTa’s fault but it’s still very frustrating when it’s the only device which won’t connect.

I’m so over this networking nonsense. I’m way over tired, unwell and have no energy to resolve.

I just can’t get any data/networking people here.

Other stuff I just plug in the ethernet cable and it just solves the problem. The Solar Assistant Raspberry Pi, the Fronius inverter are the same.

Stupid Telstra network junk.

Still having trouble. I’m trying to reset the IoTaWatt’s Wi-Fi connection but I can’t access the IoTaWatt’s set up screen.

The LEDs are showing the red green green sequence.

And when I look for the IoTaWatt’s Wi_fi I get this:

but the set up screen never appears like it used to.

That’s as far as it gets.

I have done a power cycle of the IoTaWatt.

Because you have already done the config of the iotawatt you probably will not get the auto redirect

Once youhave attached to that SSID then try and open your browser and go to


Thanks, doesn’t get me anywhere I’m afraid.

Waiting for my wife to finish working and I’ll do a router reboot.

I can see it locally now but it’s not showing an local IP address:

Yet the log says it’s connected to a local IP address:

** Restart **

SD initialized.
4/19/23 05:49:51z Real Time Clock is running. Unix time 1681883391 
4/19/23 05:49:51z Reset Reason: Power-fail restart.
4/19/23 05:49:51z ESP8266 ID: 15763621, RTC PCF8523 (68)
4/19/23 05:49:51z IoTaWatt 5.0, Firmware version 02_08_02
4/19/23 05:49:51z SPIFFS mounted.
4/19/23 15:49:51 Local time zone: +10:00, using DST/BST when in effect.
4/19/23 15:49:51 device name: IotaWatt
4/19/23 15:49:54 Connecting with WiFiManager.
4/19/23 16:01:54 HTTP server started
4/19/23 16:01:54 WiFi connected. SSID=Telstra25BEB0, IP=, channel=2, RSSI -51db
4/19/23 16:01:54 timeSync: service started.
4/19/23 16:01:54 statService: started.
4/19/23 16:01:54 Updater: service started. Auto-update class is MINOR
4/19/23 16:01:55 dataLog: service started.
4/19/23 16:01:55 dataLog: Last log entry 04/19/23 15:49:35
4/19/23 16:01:59 historyLog: service started.
4/19/23 16:02:01 historyLog: Last log entry 04/19/23 15:49:00
4/19/23 17:33:47 WiFi disconnected.
4/19/23 17:35:11 WiFi connected. SSID=Telstra25BEB0, IP=, channel=11, RSSI -79db
4/19/23 17:35:12 Updater: Auto-update is current for class MINOR.
4/19/23 17:35:29 WiFi disconnected.
4/19/23 17:36:10 WiFi connected. SSID=Telstra25BEB0, IP=, channel=11, RSSI -79db
4/19/23 17:39:46 WiFi disconnected.
4/19/23 17:39:54 WiFi connected. SSID=Telstra25BEB0, IP=, channel=2, RSSI -51db
4/19/23 17:58:07 WiFi disconnected.
4/19/23 17:58:09 WiFi connected. SSID=Telstra25BEB0, IP=, channel=11, RSSI -82db
4/19/23 17:58:55 WiFi disconnected.
4/19/23 17:58:58 WiFi connected. SSID=Telstra25BEB0, IP=, channel=1, RSSI -49db

I’ve tried rebooting router, rebooting extender, removing extender altogether, tried to reset the IoTaWatt’s Wi-Fi but it just refuses to play ball with my network.

I’m at a loss as to what to do. It’s the only device which won’t connect.

Intermittent problems are hard to debug/figure out. With the tools you are currently using, you will likely never figure out which component(s) are causing the problem. You need better tools to provide you better visibility.

I installed the app Network Analyzer. It shows all the access points it sees and it includes BSSID information. I suspect what is happening is that the Iotawatt connects to the nearer AP and that device is having difficulty talking to the rest of the network, so the Iotawatt sometimes doesn’t get an IP address.

Thanks. Yeah it’s frustrating!

I installed the Network Analyzer app but it’s not showing anything my router isn’t already. It’s just a list of connected devices and the IoTaWatt is naturally missing from that list. The IoTaWatt shows in my router but it shows as not connected.

My problem is no longer intermittent. It just refuses to connect to my network.

It’s confusing when the log say one thing (it is connected to its assigned IP address and with good signal - last update on that was just minutes ago) while the Wi-Fi status window shows something else (it’s not connected to that IP address, but to 169.254.x.x instead)?

I’ll swap out the access point today and see if that does anything.

Look at the Wi-Fi Signal tab with the phone at the location of the Iotawatt.

That will give you a picture of the Wi-Fi signals and (by using the BSSID, the hexadecimal set of numbers under the name) allow you to figure out which AP is the problematic one.

There is no such tab in the app. Info, LAN, Ping and About are the four tabs I have available.

The IoTaWatt itself is showing RSSI: -58 to -59.

I swapped out the AP but it makes no difference. The last log entry shows it’s connected to its assigned IP address but the status shows it is not.

4/20/23 06:27:59 WiFi connected. SSID=Telstra25BEB0, IP=, channel=1, RSSI -59db

My router is reporting the IoTaWatt is connected to its IP address (via the AP) but type that address in and I get nothing.

The Network Analyser app show the IoTaWatt IP address in its scan but show no connection icon (no P or B) symbol. Just N/A.


You need a Wi-Fi analyzer app, like this one:

That’s the app I am using. Mine is iPhone not Android though.

It might be time to get a cheap Android phone then. It is possible that the iPhone doesn’t provide apps access to Wi-Fi details.

Looking at the apps available for iPhone, it seems Apple believes you don’t need to know that information so they prevent you from seeing it.

Without that information, you will be in the dark. If you have a non-Apple laptop, you could get an app for that.

I just want a solution that works.

I’ve spend best part of $2000 installing this thing, trying to do everything absolutely perfectly but have no access to the data because it refuses to connect/stay connected to my Wi-Fi network even though it has perfectly good signal which everything else connects to without issue.

But because I don’t understand networking I’m struggling to work out how to resolve this problem. Buying an Android phone or a Windows computer just so I can to look up some detail sounds insane to me.

It surely can’t be this hard?

The status page says it’s not connected, the log file say it is. It’s hard for me to believe the problem is not with the IoTaWatt. If I take my other devices to where the IoTaWatt is they have zero trouble with Wi-Fi connection.

I think someone a while back suggested using an access point with a different SSID but I don’t know how that works.

I need the IoTaWatt to be visible to my primary network as the data is integrated with Home Assistant and there are home automations which use the data.

When it works it’s great but unless I can get the data it’s just a rather expensive hole in my wall.

I tried again today. I disconnect the Wi-Fi, power cycle the IoTaWatt, it goes into red green green mode, I select the IoTaWatt’s local Wi-Fi access point but it refuses to show me the set up screen. It’s not connected to anything, I have zero access to the device.

All I get is:

I’m stuck in this never ending loop of hopelessness.

If you look at this forum, you will find it is hard for a few sites/people. Networking is very hard when it doesn’t work and magical when it does, which is most of the time for most of the people.

The logs for Iotawatt indicate there IS an issue with your network, but it is not a consistent issue. There really isn’t anything anyone can do for you until you have a repeatable problem at some other site. My Iotawatts generally work fine even though the signal is marginal where they are, so it isn’t like there is a big problem that lots of people are seeing. If there was (and there was an issue with the underlying libraries in the esp8266 a few years ago) Bob would be working overtime to fix it. Right now the issue is only at your site. That likely means it is something wrong/incompatible with your network.

I think Iotawatt is a great product, but I understand networking very well and know how to configure and debug it and have the tools to see what is going on. The Apple world view is you don’t need to know this stuff, since it should just work. That is all fine for the times where stuff just works. For the times it doesn’t, I hear they have their Geniuses. Since you are in the stuff not working place, you will need to figure out how to get out of there. As I said earlier, things are not communicating and it is not clear why. This is a really hard problem to fix.

I am not clear about exactly how your network is set up even at a high level. You have some Telstra equipment and I believe the access point the Iotawatt is connected to uses wireless to connect back to the thing that has the actual Internet connection. It seems the Iotawatt can see multiple access points that all use the same SSID. I have found this type of network setup (as common as it is) to be problematic. You likely have a placement problem. You will need some tools to figure it out. I don’t think there is a different way to solve the problem and keep the Iotawatt.

might be strange but at least it just works without complaint. That is an attractive quality in a device. Which is why much of our kit is Apple.

I’ve had an offer of remote tech support from Craig, and perhaps even a trip up here (it’s a 6 hour drive) to sort it out. He is being uber generous and I am so very grateful.

It is beyond me.

I really don’t understand all the different channels being reported. There are more channels than I have routers/extenders to generate them. Makes no sense.

I pay a lot of money to Telstra for their home network equipment to avoid this sort of thing. Their tech support is useless, all they do is just mail out another extender.

Anyway, I have zero access to the IoTaWatt now. I can’t log in locally on my network, neither can I log into it its own Wi-Fi access point. It’s just a brick with a flashing LED.

I believe this is the source of your problem. Clearly Telstra is not up to the level of “it just works”. Don’t get me wrong. I do have respect for Apple and that philosophy. It is great, when it works. When something bad happens, it is extremely frustrating, since there are no tools available to help. Networking is complicated, way more complicated than most people care to learn. They shouldn’t need to, but do in some cases or depend on someone who does know.

My issue is exacerbated at times with other stresses.

I’m hoping, with Craig’s generous offer of support, I can resolve it and also learn more about this stuff.

Local district had a 10+ hour long grid power outage yesterday while I wasn’t there. So it meant the home was running entirely off-grid. This is exactly the scenario when having the data really matters, for things like load management automations.

It might take a while to resolve, I’ve now just accepted that reality.