2.4 GHz vs 5 GHz wifi

I just ran into a weird problem with an Emporia smart plug, and want to know if anyone has seen any version of this using IoTaWatt. WiFi in my house is a Linksys wireless router which supports both 2.4 GHz and 5GHz, under names like “xxxxxxx” and “xxxxxxx_5ghz”. When I tried to configure an Emporia smart plug to work with the Emporia app, I gave it the “xxxxxxx” network name and the correct password, but connection failed. I did some fiddling and became convinced that the problem was that my phone was connected to xxxxxxx_5ghz instead. I then discovered that the phone (a Google Pixel 6 running the latest Android update) was unwilling to even show me the 2.4 GHz network as long as the 5 GHz one was visible. I boxed up the plug for its return trip to Amazon this morning.

Has anyone had trouble configuring or using an IoTaWatt monitor from an Android phone running the most recent SW updates? I see that the IoTaWatt also uses 2.4 GHz wifi.

I have a Pixel 6a running Android 13 from 230205 update.

I have different names for my 2.4 and 5 GHz networks and have no trouble using or seeing multiple networks. I generally use 2.4 but just switch to 5GHz and I can see my Iotawatt just fine.

Have you already configured the Iotawatt to your network? Or, are you trying to do the configuration for the first time? Or, do you not even have an Iotawatt yet?

Assuming that the two wireless ssid are on the same subnet there should be no difference.

Device connects to Wi-Fi asks DHCP server for an ip address.
Dhcp server allocates one.
At that point device is on network and can speak to every other device on the network.

It makes no difference if the connection is wired (Ethernet), 2.4 or 5 GHz.

What can happen, if there aren’t any available ip addresses in the dhcp range (range too small, too many devices, lease time too long with lots of guests) is that the device connects to Wi-Fi, asks for an ip address, dhcp says “nope none available at the moment” If that happens the device can’t speak to other devices.

Another cause of insufficient ip addresses (Possibly) could be privacy settings on your phone changing the MAC address (which the dhcp server uses to allocate/track ip addresses). If you have a long lease time set in the server the available ip addresses could all be allocated. You could reboot your router (to clear the dhcp allocations) and shorten the lease time (how long the server waits before making the ip address available again) - I use 60 minutes.

I haven’t actually bought an IoTaWatt yet. I was just checking to see if I might expect to run into the same problems with it that I hit with the Emporita smart plugs. I still haven’t decided what kind of central monitoring I will buy.

I did get the Emporia to work this afternoon and have canceled the return.

I got the Emporia to work. What I had to do is go into the administrative app for my LinkSys wireless router and disable the 5 GHz signal, leaving only the 2.4 GHz working. After that, my phone was willing to connect to one of the 2.4 GHz signals I have (one from the LinkSys, one from the FiOS cable modem), after which I was able to configure the Emporia plug. Then, when I turned the 5 GHz back on, the plug and monitoring ontinued to work.

I am assuming that this same approach will also work with an IoTaWatt if I buy one.

Please don’t buy an IoTaWatt. What you are describing has absolutely nothing to do with the Emporia device or IoTaWatt. Maybe you could find someone with network savvy to fix your Linksys network setup. (I know, it works with everything else…)


Don’t worry, after a response like that I probably won’t. Gee whizzy!

1 Like