Blank page when trying to connect to iotawatt.local - Resolved

If the LED is glowing dull green, that is a pretty sure indication that it is connected to your WiFi and has successfully transacted with an internet time server. If you have some other LED indication, please advise.

I just experienced the same problem with a new installation, and the problem is resolved. Here is what I found: My router DHCP had assigned an IP address from a device that was turned off, so the DHCP name shown was that of the old device that was turned off, not “iotawatt”. Therefore http://iotowatt.local wouldn’t work. What did work was using the actual ip address- in my case, http://192.168.0.45. The challenge to this solution is finding the DHCP IP address that the device has been assigned. IP scanners might not show it correct, as in my case. Best bet is to find the MAC address of your device, and look for it in your DHCP client list on the router. Then, reserve that IP address for that MAC address in your Router. I would MUCH PREFER being able to set a static IP address- please, Bob?

I’m happy that you worked through this. By far, initial WiFi connection is the most difficult part of setup. The landscape of routers, firewalls, devices and browsers is impossible to deal with comprehensively.

You can easily do that through your router by assigning a static IP to the mac address. Doing it in the IoTaWatt has two disadvantages:

  • First, it would not have helped this initial connect problem as you had not yet been able to run the configuration app. Catch-22.

  • Second, from a housekeeping perspective with DHCP active, the router is the place to maintain all static IP assignments so as to avoid conflict and keep everything in one place.

Maybe I am missing something in the IotaWatt, but I don’t see a way to set a static IP address in it. I see no setting for it in the Iotawatt webpages, and search of your documentation returns no answer to setting a static IP address. I can’t assign one in the router without the device being setup up for one that I have assigned to it in the device. I CAN (and have) reserved a DHCP address with corresponding MAC address in the router that the router will give to the IotaWatt when it requests a DHCP address. This is not a static IP address. It does make sure that the IotaWatt will always get the same address when it requests one (everytime it boots up), but does NOT guarantee the router will not give this same address to another device if the IotaWatt is not present- a significant difference between DHCP assigned and static IP addresses.

I’ve never had that problem. My routers have always known not to assign those addresses to other MACs. But in the event your router works that way, if the address that you assign is not in the DHCP pool, it should work fine.