Blank page when trying to connect to iotawatt.local - Resolved

Easily got unit connected to local WiFi. Got dim green light on unit. Tried to access unit by entering http://iotawatt.local. All I got was a blank page. I tried 3 different browsers - Firefox, Chrome, and Internet Explorer. Same result even with smart phone. Smart phone (Android-Samsung S9) did say it could not connect. Browsers did not say they could not find page. Tried to disconnect using “IoTaWatt.local/command?disconnect=yes” no response still blank page. HELP!!!

Have you tried the IP address?

Yes - I tried with no results. I tried to ping this ip and it timed out. When I pinged, it responded with no errors.

I do have other devices that use this same wifi to connect to the internet. They can also be connected to locally through this wifi. Could this cause a problem? Do I need to change the ip address for the iotawatt to make sure it is not trying to use the same one as any of the other devices?

You report this condition with three different browsers. Typically, the browser will display a symbol in the tab to indicate that it has made a request of the host and is waiting for a response. In the case where there is no response, it can take up to several minutes before the browser gives up the ghost and displays a message saying that the host was unavailable or something similar. If your browser is not doing that, it indicates that a blank page was actually fetched from the IoTaWatt.

While possible, I don’t think that’s the case. To prove it out, on Firefox, press PF12 to activate the javascript debugger, then try to reload the iotawatt.local URL. Select the “network” tab in the debugger. Here’s what I get when I load the configuration app:

What do you get?

I suspect that it is a WiFi/LAN issue. Are the three browsers that you tried all on the same computer? If so, is that computer on the same network as the IoTaWatt? Is the computer wired vs WiFi? Are there any firewalls in place?

When you tried with the smartphone, was it connected to the same LAN as the IoTaWatt?

If the IoTaWatt is glowing dull green, it has connected to a WiFi network and has successfully retrieved the time from a network time server over the internet. Now all we need to do is figure out why you can’t locate it. sounds like the address of a router / gateway address. Do you have multiple WiFi routers in your configuration? Is that the address your DHCP server is providing? Can you see the IW in the DHCP address list?

I’ve locked my Iotawatt to a specific address with a DHCP reservation and always connect locally using the IP address.

1 Like

I do the same using a DHCP reserve and always know the IP address of my IoTaWatt and use this to connect.

Sorry for the delay in getting back to you. I appreciate the response. I do have very limited knowledge of networking. I can answer your question but can not try anything until this evening as I am at work.

The three browsers were in the same computer. The computer is a Surface so all I have available for connections is WiFi. I am checking with our IT person at work about firewalls as this is a computer that is on a network at work when I am there.

I also tried an IPad with Safari and got the same result. I believe you are correct about the blank page and not waiting long enough. As I could ping IotaWatt and get a response.

I have two WiFi connections in the house. One is simply an extender. All the devices I attempted to connect with were using the same WiFi as the IotaWatt.

As I understand it, the DCHP must be handled by the router the cable company provided.

I do have a light switch, a piece of water equipment, and a solar system that use the same WiFi to connect to the internet. The only other devices that would be on this system are my Surface, IPad, IPhone and an Android phone.

Again thank for any help you can provide. I will let you know the out come of the test you have asked me to try.

You may want to try using a network scanning tool such as “Fing” which works on Android or iOS. Once installed, you can use this to scan you network for IPs and then test connecting to the IPs it lists. Some devices show up as generic which is how it shows my IoTaWatt. Not the long-term solution, but a solution to get the right IP to device at this time. The router the provider gave to you may allow you to configure DHCP allowing you to give the device a static (fixed) IP forever. I do this on mine based on the device MAC address which is also shown in the Fing app.

Be aware that WiFi Extender often rewrite the MAC address of device on the extension side, so it will be different based on how the browser picks up the IoTaWatt. I would install and run Fing first and see what device and such are on your network.

I did what overeasy recommended. It is looking like Iotawatt is just not responding after the second request.

It appears Iotawatt is failing to go forward from the second request.

Can anybody make a suggestion as to why other than there may be a corrupt image file that is stopping the program.

Is there any way to reset the Iotawatt to see if that makes a difference?

Those pump curves are nice, but no substitute for the javascript debug output.

Sorry all. I don’t know where that image came from. I hope this attempt is better

Hmmmmm. That’s a new one. Just what you wanted to hear I’m sure.

It does look as if the iotawatt is serving up a bogus file. Let’s see what else is going on. Can you try the following?




Here is what I got trying the three different actions.

Can you do the iotawatt.local/index.htm again, and then click on the index.htm line in the debug screen. The right side will then show the request and headers. Post that, then click the response tab and post that.


This is what I got.

I don’t think you are communicating with the IoTaWatt. You previously said you were using the DHCP of the router provided by you able company. The IP address that your computer says it’s talking to is That doesn’t look like the kind of IP that a cable company router would assign to a ldevice on a local LAN. I’m also baffled by the cache reference in one of the above test requests.

Do you have some kind of VPN installed on your computer or router? This is looking more like a network topology problem.

UPDATE: I looked up that IP and it is owned by Akamai Technologies. They are a content delivery network (CDN) and provide cache services. So bottom line is that your request is being sent out over the internet. How the .local URL was translated to an outside IP is a mystery to me, but it does seem to be happening.

What happens when you try to use the Ipad and Iphone?

I did try the IPad and as I recall it did time out where as with the Surface it is truly a blank page. I will need to confirm this as I have tried so many different avenues. I think it would be helpful to have me try that again to confirm.

If I am getting an outside address how do I prevent that from happening and why might it be happening. As I think about it there is only one device that I connect to locally through the WiFi otherwise the devices are connected to the outside world and I connect to them through the device service providers server. The one system I have that I connect to directly through the my local cable WiFi does not have this issue. Hope that helps.

Below is original response before I got UPDATE

I don’t know about the router. It is provided by Spectrum. I have no trouble communicating with other devices connected to it. I have already mentioned that.

I do use a VPN to log onto my work server remotely but that has to be turned on and off depending on what I am doing. It does not let me be connected to the company server and at the same time cruise the internet. I have to work inside the tunnel when connected. Otherwise it is not supposed to be doing anything. If that were the problem, I would not expect the other devices ( IPad, IPhone, and Android phone) in the house to have the same problem.

I am guessing that there are other customers of IoTaWatt that use Spectrum devices. If the Spectrum router/WiFi was the problem, I would think others would have the same problem.

Some on this thread have suggested assigning a static IP. I don’t know how to do that but is that a possible thing to try since you
think the IP provided may not be coming from the router.

LAN topology and all of the possibilities are endless. Only the largest companies can even begin to dedicate resources to resolve these kinds of issues. Safe to say that if the IoTaWatt doesn’t get the request, it can’t respond to it.

I do think that knowing the IP address of the IoTaWatt would facilitate connecting to it. The “zeroconfig” .local method works most of the time, but there are limitations beyond the control of the receiving host. Basically the originating device broadcasts a message to all devices on the lan asking if there is anyone out there that calls themselves iotawatt. We listen for that and will respond with a message to the sender containing our IP address. Devices originating such connections will remember the name and corresponding IP for subsequent transactions.

So if that isn’t working or isn’t a protocol supported by your PC, you will need the IP address. As far as I know all Apple devices support it because they invented it with their Bonjour service to identify local printers.

One of the replies above references an app that you can use to discover the iotawatt’s IP address. Most routers have the ability to log-in and look at a connected device list. If you can login to the router, yopu can also assign a static local IP to the IoTaWatt.

If you know someone who can do these things, and its becoming a fairly common skill, then I would encourage you to reach out for help.

If it is my understanding that you believe this is the only problem that is causing us to not get the information from IoTaWatt, I will see what I can find out about getting the IP for the IoTaWatt. This may be why others have gone to a fixed IP on their systems. I have some resources that may be able to help me with this.

One last thing before I do that. Is there some way to now connect directly to the IoTaWatt’s WiFi and test it to see that it will present the set up information? Would this confirm the device is working properly and the problem is not that it cannot send out information.

Thank you for all the help so far.

Based on what I have found out I believe I will try what you suggested. Thank you for the help. I will post what I find so other may benefit.