Brand new ioTaWatt not working - SD issue?

Hello Everyone,

Very excited about this project. I just bought an ioTaWatt from’s store and began setting it up.

Unfortunately I have hit two likely related issues

  1. The captive portal page did not load. I connected to the wifi network and my computer was given an IP address ( but the page at would not load. To combat this I power cycled the ioTaWatt, which did not resolve the issue.
  2. Then I noticed that it was flashing GREEN-RED-RED, an indication of an SD issue. To debug, i tried all the following things, testing the device in-between each step:
  • I opened up the device and saw the card was seated fine
  • I re-seated the card
  • I successfully read from the card on my computer.
  • I grabbed new copies of the SD files from Github and placed them on the card
  • I reformatted the card (MS-DOS and MBR) and put the files on
  • I tried a new card of mine which works fine (32GB), formatted it and put the files on.

Nothing has worked, so right now I just have a Christmas-themed strobe light.
Trying to make this work from the US, so shipping wouldn’t be my favorite option.

Any suggestions?

Thanks so much,

Sorry to hear you are having this problem. Did you get your power supply from OEM and if not, what are you using?

Hello @overeasy, yes I bought the microusb supply and 9V AC brick (shouldn’t be relevant at this moment) from OEM. I just tried a different micro usb supply and am seeing the same issue.

Thank you

Thanks. I am an OEM (Original Equipment Manufacturer) to OEM (Open Energy Monitor) and supply them with PCBs and enclosures. They assemble the units and provide formatted and loaded SDcards. The PCBs are factory tested with firmware that tests the SDcard hardware. So i’m caught in the middle with no real insight into what might be happening.

The only other instance of this appears to have been just a loose card, so what you are reporting is different. You seem to have exhausted the field options. If you would like to avoid returning to the UK, I can take the unit here in the USA, diagnose or replace it, and work it out with OEM. I would need to have the unit shipped to me via USPS small flat rate box ($7.12). The IoTaWatt unit with the original SDcard installed. I would return by same. I have no mechanism to credit you the postage, but I will ask the question to OEM and see what they say.

If you want to do that, let me know and I’ll PM the address to send.

Hello @overeasy, sure that sounds like the most efficient solution. Thank you!


Unit is on its way back. reformatted SDcard to fat32 and loaded SD files, captive portal now comes up on my IOS device.

Flashed to 02_03_13. You will probably need to set the VT to the USA Ideal.

Good luck.

Glad to hear it! Thank you so much.

Any idea why this occurred?

Nope. The SDcard was formatted with some kind of mac format stuff. I just reformatted to Fat32 and loaded the SD files and it started right up. If you have trouble, give me a crack at it before you open it up again.

@overeasy, Sounds good. Thank you

Hello @overeasy, thank you for sending the iotaWatt back.

Unfortunately I just plugged it in and am again seeing the Green-Red-Red flashing, and no Ad-hoc network is showing up from the device on my computer or phone. This is also with a different 5V USB supply and cable, both of which work fine with other devices.

How could this be? What next steps should I take?

Thank you,

I checked it right before I put it in the box and it was red-green-green with the AP active. So here’s what I’d like if you could:

Power down the IoTaWatt.
Open it and remove the SDcard.
Take the SDcard to another computer and copy the file /iotawatt/iotamsgs.txt
Post that file.

Leave the IoTaWatt open and powered down, and leave the SDcard as is.


Hi @overeasy, sounds good. My micro SD card reader is at work, so I’ll have this file for you tomorrow morning.

Thank you!

Hello @overeasy, that file does not seem to exist on the SD card. The only files I see on the card are the same 7 ones as last time I read it from my computer. This is consistent in both the Mac OS Finder and Terminal:


Hi @pomplesiegel,

That’s useful information. Next step is to put the SDcard back in and power it up using a USB cable from your computer rather than the USB power supply. See if that is any different.


Hello @overeasy, I re-seated the SD card and powered on the device using my macbook as the 5v supply. It came on and the AP appeared, allowing me to point it to my home wifi network. However, then it flashed Red-Red-Red.
I gave it a bunch of time but then eventually restarted it, as it did not join the network and acccording to the docs, it seemed quite unhappy.

After more exploration it now seems that there it a little bit of mechanical “play” to the SD card reader on this particular PCB. By wiggling it very gently, ever-so slightly I can still get the device to become upset, resulting in the LEDs flashing.

Would you be willing to potentially provide a replacement PCB? I’m trying to get going with this device but unfortunately I’m currently quite far away from something I can use.

Thank you,

Ok, I’ll try to take care of that tomorrow.

Great, thank you so much for your help!

@overeasy, anything you need from me? Thanks so much for agreeing to help.

Should be delivered today. 9400110897773042007391

There is a pre-paid return label inside. Just send the old one back in the same box with the return label at your earliest convenience. I’d like to take a closer look at that SDcard slot.

Thanks for your patience.

@overeasy, Amazing! Thank you so much.