Captive Portal Wifi Network type at office wont allow me to connect

I recently got an IoTaWatt to setup. I am able to connect my iPhone to the IoTaWatt’s wifi and that captive portal opens fine. I find the wifi network for the office that I am in and when I go to put in the credentials, there is just the SSID and Password fields. The wifi network at this office has a captive portal of its own where you sign in through email. Has anyone figured out how to connect the IoTa to this type of network? Is it even possible?

I have talked to the office management team and they took down the MAC address to send to the network people to make a bypass but that hasn’t worked so far. I have also tried using the personal hotspot from the iPhone since that does not have a captive portal…but that doesn’t seem to work either.

The IoTa just blinks RGG when trying to connect and nothing happens even after waiting more than 10 minutes, which is weird because the documentation says it should change codes after a while.

Any help would be great thank you.

When you say you only can enter SSID and passkey, are you saying that the IotaWatt captive portal does not list the network as a selection? If so, and the network is set to broadcast its SSID, then it may not be a 5 GHz network which is not supported. It must be 2.4 GHz b/g/n. Also, some more rigorous authentication protocols may not be supported.

No it does list the network on the Iota captive portal. When i click the desired network that goes into the SSID field. I was just trying to explain that it seems there isn’t a way to submit a user name and password or go to the networks captive portal.

So are you saying that this type of network does not have a workaround and isn’t supported?

I was just trying to figure out what the problem is. If the IoTaWatt LED is RGG, then it isn’t connected to your network. In order to get a captive portal, it must first connect to the network.

But to somewhat answer your question, no, the IoTaWatt has no capability to respond to another level of authentication through a captive portal or other non-standard logon. It supports the standard WiFi authentication methods only.

I’d like to see the captive portal. Can you connect to the office network with your phone and take a screen shot of it? Also, can you connect the IoTaWatt to your phone hotspot and post the message log?

Thank you for trying to help me.

This is a screenshot of the office network captive portal:

And when I try to connect the IoTaWatt to my phone hotspot, this is what I get:

I just see this message and the RGG LED pattern indefinitely.

As I suspected, the Captive Portal is security gateway unique to your office environment. There is no facility in IoTaWatt to dialog with that. We only use standard WiFi authentication protocols.

I’m not familiar with what goes on during the connection handshake using that second level authentication. It seems to me that a connection would need to be established between the IoTaWatt and your network using the SSID and key before the captive portal could be sent. The IoTaWatt would not be aware of that and would turn off the RGG assuming the connection was made. I could be wrong about that, but it suggests that the basic connection is not being made. Also, you say the administrator tried to suppress the captive portal to your MAC address, so that should have worked. I’d be curious to see the IoTaWatt message log. If you can connect the unit to your home network, maybe you can copy out the message log.

Okay I see. I am a little confused by what you mean with this part:

Other than that, the unfortunate thing is that I am living in an apartment accomodation right now so I don’t have a private network. When I leave the office today I will go home and try that out and report back to see if it helps at all, but if I am not mistaken, my appartment wifi network also has a captive portal of its own with a username and password… :grimacing:

So I am not really sure where to go from there. I will talk to my superiors maybe and get a separate wifi network setup for this??? I guess it depends on what they say.

I appreciate your help thus far though. I will try it at my apartment and if not that then I am a bit stumped.

Sorry I forgot to add this:
I agree that the MAC address bypass should have worked. Is it possible that I gave them the wrong one? When I connect to the IoTaWatt with my phone, I get to its captive portal. From there I saw the “Info” selection and then there are two values at the bottom, the soft ap MAC and the station MAC. I gave both to the office management people because I was unsure which was the right one I needed. Are either/both of those the right MAC addresses to use to do the captive portal bypass on the office network?

Station MAC.

So the way I understand it, the underlying WiFi layers establish a connection between the AP and the IoTaWatt using the SSID and “password”. That establishes a connection and clears the way for communication. The way I understand captive to work, is that the router responds to any request from the device with the captive portal page and waits for a response. While it is waiting, the two are “connected” in the traditional sense of the term. The IoTaWatt firmware should have received a connection notification callback and logged a connection in the message log.

Meanwhile, the router is waiting for a response from the captive portal page before it will allow any other traffic on the connection. It probably has a time limit for response and would drop the underlying connection when that lapses. The IoTaWatt however should have ceased the RGG LED indication when the initial connection was established before the captive portal handshake. The LED should have gone to all red or all green depending on whether it has had the RTC clock set (green). When the router subsequently drops the connection, it would go to solid red and stay that way until a power-on reset.

I may be missing something here, but by that sequence of events, it doesn’t appear that the initial WiFi connection at he SSID/password level was successful.

1 Like

Yeah that all makes sense to me about the lights changing when the connection is undergoing different phases. I have not observed a light change so I agree with you that it has never successfully established a connection. With that in mind though, it doesn’t seem that it is possible to establish a connection to this type of captive portal network. I did give the office management the station MAC and they got back to me saying the network team cleared them. It would seem then that I have run into a deadend. I believe my superiors are okay with getting a private network setup at the office for my team and I to continue using this.

Hopefully there is a good update at some point, but for now, I have really appreciated your patience and explanations on my situation. Thank you.