Confused - Need some guidance - resolved

I received and installed the IoTaWatt unit today and I’ve been trying to get everything figured out.

I have 9 inputs configured (mains + 8 circuits in the building). Everything seems to be working, but I have a weird problem.

I’ve configured 2 outputs:

  1. Combination of all circuits (excl mains)
  2. Main - combination of all circuits.

Looking at the status page, output 1 is higher than mains and output 2 gives me a negative value. Should output 1 not be relatively close to the mains input? And the difference between mains and output 2 be relatively close to 0?

I might have missed something simple. If so, please point me in the right direction.


It is a simple setup, and everything seems to be setup correctly. The first thing is to double check the CTs on the mains. See if it may not be closed securely. I’d recommend taking it off and putting back on. If that yields the same result, try swapping the mains CT with one of the others, but mark it somehow so you don’t lose track of it.

I suspect the mains CT for two reasons:

  • When CTs are off, they are usually low.
  • The power factors of the two highest use circuits are 1.00 and .97, so I wouldn’t expect those to blend into 0.96 as measured at the mains.

So give that a try. If those are all of the branch circuits, I would expect the whole thing to reconcile to within a few watts.

Thanks for the response. I’ve removed and re-added the mains CT, but I have not yet swopped it with another one.

After re-adding it, I am still experiencing the same reading. I have however picked something up, when checking everything: All the CTs are the blue SCT013 100A (marked with 100A:50mA) models, except for one (currently connected to 8 - Plugs_3). This one is a SCT013 30A (marked with 30A/1V).

SCT013 100A -
SCT013 30A -

Could this possibly be the reason for the difference between mains and combination of the other circuits?


No, that will cause the reading to be too low rather than too high, and even if that input were zero, the numbers would still not add up.

It sounds as if you may have a batch of CTs of dubious origin. While SCT013-000 has been a workhorse and are usually pretty accurate, I have had some that read chronically low. Maybe a hairline crack in the brittle iron core, maybe a leak in the TVS diode, maybe a short in the winding. It’s probably a good idea to test them for consistency.

If you have an accessible length of mains cable or the outbuilding cable, you might just try clipping all of the CTs around it at the same time to see how close they read. If there are outliers, try swapping the input channel with another “good” one. If the problem moves, it’s the CT. If it stays on that channel, maybe it’s the IoTaWatt. Haven’t had any quality problems like that, but there’s always a first time.

Regardless of where the fault lies, it should be corrected and the inputs should add up very close to the mains. I say close to the mains because the SCT013-000 isn’t the best option for low wattage circuits. They have a lot of phase shift at low current and can also be a little off on linearity. The problem is compounded in 230V countries where the current for a given power is half. There are better choices for those circuits.

1 Like

I’ve done some further testing today.

I could connect a max of 3 CTs to the mains at the same time. So I tested 3 at a time. Every time all 3 were very close in measurement - within a few watts of each other. I repeated this with all the CTs and had the same results.

I also purchased a new SCT013-000 today to replace the 30A CT I had. I replaced all the CTs, ensuring the they were all closed properly. It was quite tricky to get all of them in, as the space available is quite limited.

After everything was connected again, I went around the house switching on all the lights and some appliances to test. it seems something I did sorted out my problem, as the difference between mains and the combination of the other circuits are now within a few watts - (between 5 - 20 watts)… Mostly around the 5 - 7 watt mark.

Thanks for the help.

That’s less than 1%, which is what I strive for and have come to expect. Thanks for the confirmation.

1 Like