Device name is locked

I tried to rename the device name which I had running for a couple of days but it is locked and doesn’t allow me to change it.
The only things I have done are:
1- Added my inputs
2- Added an uploaded to influxdb2

As you might be able to see in the image the Device name is gereyed out:

Any ideas?

No idea, have you tried refreshing the browser window?

Tried different browsers, different computers… I actually received my second device today and I could change the Device name.
Then added the uploader and applied passwords to both Admin and User without unrestricted LAN access and now I can’t change the name on the second device as well.
So it has either to do with the data uploader or the password function.
I set the same password and different passwords. The problem is still the same!!!

Is there another way to change the device name?
I also tried editing the config.txt but I’m getting this error:

I managed to fix it by playing around. I reset the password to blank and ticked the LAN Unrestricted access. Saved the new blank passwords. Refreshed the page and I could change the device name… Very Strange!!!