Did I fry my Iotawatt

I bought a second Iotawatt because the first one was so awesome, but I wanted to monitor more stuff. Got the second one all running and I figured I’d just share the reference voltage transformer between the two of them with a barrel jack splitter. They both boot up fine but I’m not getting a reference voltage on either of the devices even with just one device plugged in the original way that it was working.

I’ve checked the VT with a multi-meter and its working. I even pulled the new one apart and check to make sure it was getting power at the barrel jack and it seemed fine.

Did I cook them?


Don’t panic. If you really fried anything, there would have been smoke, but it may take a while to figure out what’s going on.

Splitters are not a problem as long as they maintain polarity. With the VT plugged into the splitter, there should be no voltage between the two outer barrels and no voltage between the two inner pin sockets. On the other hand the voltage should be evident between the outer barrels and the inner pin sockets. Can you check that to see if there is an issue?

Next. If your second unit is a V5 unit, it will have two additional VT inputs. Can you configure one or both of them as your VT? They are channels 13 and 14 as marked. You must remove any CT plugged into those 3.5mm inputs. See if there is any voltage displayed in the status screen with the VT (sans splitter) plugged into them… Report back.

Lets see the results of that and go from there. Are you in the USA?

Update, I just checked and you do have a V5. Also, you are about 120 miles away, or basically a day by mail. So if it comes to it, I can fix these units with a few days turnover.

I just tried the other two reference jacks still no go. I’d be happy to send them off today if your willing to take a look.


IoTaWatt, Inc.
PO Box 1679
Wolfeboro, NH 03894

Were the two units powered by two independent USB power supplies, or was there something like a USB hub or other common source?

One of those shared USB power bricks.

Can you send the AC splitter as well?

Sorry I just shipped it out, that was stupid I should have included that.

Its just that you didn’t say if you did the tests that I described above to insure polarity is preserved, which would definitely cause trouble with the common ground of a shared USB power supply.

So I just checked and you’re exactly right, the polarity was swapped on one of the devices. I (stupidly) assumed that the dashed lined on the cords would map to the correct sides of the barrel jack. I should have checked first.

If you’re able to fix them great otherwise thanks for taking a look.


Just finishing up. The op-amps were blown in both units, but that appears to be the extent of it. I replaced them. Ran diagnostics on the V5 unit and it passes all tests. Didn’t run diagnostics on the older 4.8 unit because not handy, but did bench test all the voltages and it looks fine.

I’ll send you a good splitter.


AWESOME! You’re the best. Thanks