Dropdown setup menus stuck on iPad

Just received my first IoTaWatt today and did a partial install tonight.

The New Connection to my WiFi network was flawless on my iPad (iOS 13.4.1).

However, when trying to configure the devices, the dropdown menu (Device/Inputs/Outputs/…) seemed stuck in place, so I couldn’t select the button for the first input to configure it. Anyone else experienced this, or know a special gesture that I might have missed? (I tried tapping on the background, swiping, etc.) I tried Apple’s built-in Safari browser, along with Firefox and DuckDuckGo browsers, which all exhibited the same behavior.

I had to go to my desktop computer to finish the setup, so not a blocker, more of an annoyance.

Looking forward to discovering all kinds of interesting things with my energy usage with the IoTaWatt!

That has always been an annoying problem on IOS. What I do to workaround is press one of the exposed inputs, then cancel the edit submenu. It returns to the inputs display sans the menu drop down. If anyone can figure how to eliminate this problem in the html, it would be helpful.