GRRG LED sequence

I successfully set my IotaWatt yesterday and it was a beautiful thing, recording power consumption on 2 channels. It was the unit I purchased from OEM a few years back, not the one recently purchased from IoTaWatt directly.
I upgraded the firmware to 02_05_09. At some point I messed up the unit while working in the Device configuration window. Now I’m getting a Green Red Red Green LED sequence. I read in the Troubleshooting section of the guide that the config.txt file may be the issue. I’ve looked at that file using a JSON linter and found no issues. I uploaded an original config.txt file from https://github.com/boblemaire/IoTaWatt/blob/02_04_02/SD/config.txt and that did not fix the issue. When I load the unit in my browser I get the IotaWatt Power Monitor screen with the Setup, Tools, Status, and Data options (functional), but under those buttons it says ‘configuration not found’.
In trying to rectify the issue I now have screwed up the File Manager directory structure. I now have 2 esp_spiffs directories (after I added the config.txt file to the root directory. In trying to delete one of them I lost the former config directory that contained a burden.txt file. I haven’t been able to find that file in the GIT repository.
image
I’m wondering if I should start all over with a fresh SD file system, or can I repair what’s left of my files.
I can modify the files using the embedded Ace Editor.

I think you may have inadvertently created the extra esp_spiffs directory on the SD card. Unfortunately, there is no way to remove that e3xcept by mounting the SDcard in another computer. That said, I think it’s probably harmless. What do you get if you try to edit the config that is in either of the esp_spiffs (the contents shown in each should be the contents of the actual esp_spiffs).?

Can you download that file?

Can you post the contents of that file?

I’ll check back in 20-30 minutes and see if you have responded. I think this can be fixed pretty easily, but will require a dialogue.

Thanks for the quick reply (as always),
Follows is the downloaded config.txt file that is currently in the esp_spiffs directory:
{
“format”: 2,
“timezone”: 0,
“update”: “MINOR”,
“device”: {
“name”: “IotaWatt”,
“version”: 3,
“channels”: “15”,
“burden”: [
0,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24
]
},
“inputs”: [
{
“channel”: 0,
“name”: “Input_0”,
“type”: “VT”,
“model”: “TDC DA-10-09-E6”,
“phase”: 1.49,
“cal”: 10.79
},
null,
null,
null,
null,
null,
null,
null,
null,
null,
null,
null,
null,
null,
null
],
“outputs”: [],
“server”: {
“type”: “none”
}
}

The version that existed when the GRRG issues started was:
{
“format”: 2,
“timezone”: “-5”,
“device”: {
“name”: “iotawt1”,
“version”: 3,
“channels”: “15”,
“burden”: [
0,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24
]
},
“inputs”: [
{
“channel”: 0,
“name”: “Voltage”,
“type”: “VT”,
“model”: “TDC DA-10-09-E6”,
“cal”: 10.79
},
{
“channel”: 1,
“name”: “Garage”,
“type”: “CT”,
“model”: “AcuCT-H040-50”,
“phase”: 1,
“turns”: 1000,
“cal”: 41.666666666666664
},
{
“channel”: 2,
“name”: “GrdRmSpt”,
“type”: “CT”,
“model”: “AcuCT-H040-50”,
“phase”: 1,
“turns”: 1000,
“cal”: “41.67”
},
null,
null,
null,
null,
null,
null,
null,
null,
null,
null,
null,
null
],
“outputs”: [],
“server”: {
“type”: “none”
},
“update”: “MINOR”,
“dstrule”: {
“adj”: 60,
“utc”: false,
“begin”: {
“month”: 3,
“weekday”: 1,
“instance”: 2,
“time”: 120
},
“end”: {
“month”: 11,
“weekday”: 1,
“instance”: 1,
“time”: 120
}
}
}

Follows is the log from the last restart:
** Restart **

SD initialized.
6/28/20 18:23:25z Real Time Clock is running. Unix time 1593368605
6/28/20 18:23:25z Reset reason: Software/System restart
6/28/20 18:23:25z Trace: 1:6, 1:3, 1:4, 1:5[19], 1:6, 1:3, 1:4, 1:5[19], 1:6, 1:3, 1:4, 1:5[19], 1:6, 1:3, 1:4, 1:5[19], 1:6, 1:3, 1:4, 1:5[19], 1:6, 1:3, 1:4, 1:5[19], 1:6, 1:3, 1:4, 1:5[19], 1:6, 1:3, 10:2, 10:3
6/28/20 18:23:25z ESP8266 ChipID: 451813
6/28/20 18:23:25z IoTaWatt 4.x, Firmware version 02_05_09
6/28/20 18:23:25z SPIFFS mounted.
6/28/20 18:23:25z Config file open failed.
6/28/20 18:23:25z Local time zone: +0:00
6/28/20 18:23:25z device name: IotaWatt
6/28/20 18:23:25z HTTP server started
6/28/20 18:23:25z timeSync: service started.
6/28/20 18:23:25z statService: started.
6/28/20 18:23:29z WiFi connected. SSID=redacted, IP=192.168.1.204, channel=8, RSSI -78db
6/28/20 18:23:29z MDNS responder started for hostname IotaWatt
6/28/20 18:23:29z LLMNR responder started for hostname IotaWatt
6/28/20 18:23:29z Updater: service started. Auto-update class is NONE

Also, can you point me to how to recreate the config directory? Using the MkDir feature just created what looks like a file (no folder icon). For this reason I can’t reload the burden.txt file (if and/or when I find it).

I can successfully edit the config.txt file in the editor. I confimed this by changing MINOR to MAJOR.

OK, the config that you posted fails the linter because somewhare along the line the quotes got changed to left/right quotes. If you have a copy of the pre GRRG config with standard quotes that passes Lint, can you upload it to the root directory and restart?

I’m not seeing left/right quotes in the file I upload into the IotaWatt Message Area (although they clearly exist in the files that I uploaded). Also, I’m not sure if I’m successfully uploading to the root directory. I’m using /config.txt but it doesn’t show up in the root directory.
Also, I had run the files through the JSONLint validator and it didn’t through any errors. I’m going to paste the file again to see if the left/right quotes are generated during when I upload to this forum platform:

{
“format”: 2,
“timezone”: “-5”,
“device”: {
“name”: “iotawt1”,
“version”: 3,
“channels”: “15”,
“burden”: [
0,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24,
24
]
},
“inputs”: [
{
“channel”: 0,
“name”: “Voltage”,
“type”: “VT”,
“model”: “TDC DA-10-09-E6”,
“cal”: 10.79
},
{
“channel”: 1,
“name”: “Garage”,
“type”: “CT”,
“model”: “AcuCT-H040-50”,
“phase”: 1,
“turns”: 1000,
“cal”: 41.666666666666664
},
{
“channel”: 2,
“name”: “GrdRmSpt”,
“type”: “CT”,
“model”: “AcuCT-H040-50”,
“phase”: 1,
“turns”: 1000,
“cal”: “41.67”
},
null,
null,
null,
null,
null,
null,
null,
null,
null,
null,
null,
null
],
“outputs”: [],
“server”: {
“type”: “none”
},
“update”: “MINOR”,
“dstrule”: {
“adj”: 60,
“utc”: false,
“begin”: {
“month”: 3,
“weekday”: 1,
“instance”: 2,
“time”: 120
},
“end”: {
“month”: 11,
“weekday”: 1,
“instance”: 1,
“time”: 120
}
}
}

So when I upload the files it appears as if this messaging platform produces the left/right quotes. Is that possible, or do I wishfully think?

From the file manager, you would click the “browse” button at the top left and using whatever file selection method your browser supports, select the file. in the window, be sure the filename is /config.txt and click the upload button. If the file doesn’t appear in the SD root, then refresh the browser window.

When I upload the pre-GRRG i get the same issues. Both files (pre-GRRG and the config.txt downloaded from Github successfully pass the JASON linter, but aren’t recognized by the IoTaWatt).

So when I upload the files it appears as if this messaging platform produces the left/right quotes. Is that possible, or do I wishfully think?

Directory image right before selecting Upload -

image

After uploading the file to root -

image

No change

Did you refresh the window?

Yes sir, sorry I didn’t mention that.
Refreshed the window, and just in case, reloaded from the URL without /edit.htm. Then went to Tools/File Manager and Editor.
No change.

OK, then I’m not liking your SDcard directory. It may be time to remove the SDcard and reformat (fat32), then reload the files from the 02_05_09 SD directory, and then replace the config with your config.txt.
If your computer has the capability, you can copy then restore the /iotawatt/histlog.log to retain any history.

Reformatting the SD card and reloading the files from https://github.com/boblemaire/IoTaWatt/tree/master/SD repaired the startup issue. I reused my config.txt file with the CT’s already documented.
Now I just have to get the edit.htm file to work properly. Currently when I go to the Tools/File Manager and Editor the window shows “Message Area” but the rest of the screen is blank. Actually, it looks like all of the *.htm files need some TLC. The Setup is on Auto-update Class = MINOR so I’ll wait for the next update to see if the problems get resolve.
The Status feature is updating properly.
Thanks for the help this Sunday.!

The config/status is index.htm so it’s not all .htm. See if Graph+ works. To debug the editor, hit PF12 to start the browser debugger, then run the editor. Post the debug window with both the Console and Network tabs active and I’ll take a look.

Not sure what PF12 means, but by the looks of your screenshot it is the inspect function after loading the Tools/File Manager and Editor options

Console:

Network:

Looks like there may be some intel on the edit.htm file.

Yea, sorry F12 (on windows). I think that file may be damaged. Might want to upload it again.

I figured it out. I cloned the SD card from my new IoTaWatt (nice case modification) and compared the files. It turns out that when I copied the raw files from Github I was presented with an option to translate to English from Maltese


Like a true 'merican and blind truster of all things Google and Windows I chose the native language… Grrrrrr! It adds a space before and after all = characters.

No wonder all .htm files weren’t working properly, i.e. Edit, Graph, Graph2, etc.

Thanks for all of your time yesterday. Hopefully this will save others the wasted time.

1 Like