Help please - new install - Can't create Outputs

I’m a new user with some tech background. Just received and am experimenting with new unit. Main problem is with the Outputs. Initially I was able to create about 4 Outputs. They worked fine, although I was not able to see them in the list of Inputs for creating new Outputs. Then it would not let me create another (I think it stopped at 4). I tried rebooting, tried deleting all Outputs and starting over. It has gotten worse and I cannot add any now. The main issue is that the screen for creating an Output is no longer showing the button to “Save” an output at the bottom of the screen. It comes up as shown below. I can describe the output, but I can’t save it because the Save button is gone.

Any help would be greatly appreciated. I’m very excited by what I’ve been able to do so far, in spite of this glitch.

My order number was 129025, January 30, 2024.

There is no save in the posted screenshot because there is no name.

Outputs do not appear in the input. Outputs can only reference inputs, integrators and constants.