Incorrect value

Hi I have put a CT on solar output which has a maximum of 5KW, I am recording upto 8Kw, any ideas how I can fix this, thanks in advance

Most likely something with the configuration setup. Could you post a screenshot of the input setup, a screenshot of your status display, and if possible, a picture of the panel showing the CT installed on the inverter output?

I will send install photos on weekend

I see that you have the solar CT configured as generic. I’ll need to know what you have specified for turns ratio as that is almost certainly incorrect and the source of the error.

Thankyou, I used the data sheet to set up the generic CT, I’ll replace it with one I was sent and let you know how I get on, thanks for your speedy response and great support

Thankyou all fixed, I had also checked double as I am in Australia, but records properly with double unchecked?

Right. In North America the service is split-phase with both 120V and 240V. Typical IoTaWatt installation uses a 120V reference and “doubles” for 240V circuits. Your reference is 240V so you do not double for the 240V circuits. I should have noticed the (2x) on the inputs in your earlier post. None of those circuits should be doubled.

Thanks again, now all I need to do is decide whether to use a server so I can monitor when I am away?

If you only need to see your solar generation and consumption, I’d recommend giving PVoutput a try. It’s free (nominal donations welcome), easy to setup, and has a decent phone app.

Don’t overlook the IoTaWatt’s capabilities for remote access. Most routers support port forwarding and dynamic DNS, which allows access to specific devices. If you do expose the web server to the internet, you can activate access control by setting a password, which is reasonably secure.

Thankyou I’ll try the PVoutput