Influx v2 uploader issue: HTTPS specified but no HTTPSproxy server configured

Hi - This is my first attempt to use influxDB and the IotaWatt uploader. I’m having some issues I can’t get past…

When I edit and save the uploader setup, I get an “HTTPS specified but no HTTPSproxy server configured, stopping.” error:

** Restart **

SD initialized.
4/28/23 18:07:52z Real Time Clock is running. Unix time 1682705272 
4/28/23 18:07:52z Reset reason: Exception
4/28/23 18:07:52z Trace:  10:14, 10:14, 10:14, 10:14, 10:14, 10:14, 10:14, 10:14, 10:14, 10:14, 10:15, 10:16, 10:16[1], 34:30, 34:30, 33:0, 34:30, 10:16[1], 34:30, 34:30, 33:0, 34:30, 10:16[1], 10:16[1], 10:16[1], 10:16[1], 10:16[2], 10:17, 10:17, 10:18, 10:23, 10:17
4/28/23 18:07:52z ESP8266 ID: 563800, RTC M41T81 (68)
4/28/23 18:07:52z IoTaWatt 5.0, Firmware version 02_08_02
4/28/23 18:07:52z SPIFFS mounted.
4/28/23 11:07:52 influxDB_v2: HTTPS specified but no HTTPSproxy server configured, stopping.
4/28/23 11:07:52 influxDB_v2: Invalid configuration.
4/28/23 11:07:52 Local time zone: -8:00, using DST/BST when in effect.
4/28/23 11:07:52 device name: IotaWat1
4/28/23 11:07:52 HTTP server started
4/28/23 11:07:52 timeSync: service started.
4/28/23 11:07:52 statService: started.
4/28/23 11:07:52 dataLog: service started.
4/28/23 11:07:55 dataLog: Last log entry 04/28/23 11:07:50
4/28/23 11:07:57 historyLog: service started.
4/28/23 11:07:57 historyLog: Last log entry 04/28/23 11:07:00
4/28/23 11:07:57 WiFi connected. SSID=Gochujang 2.4, IP=, channel=11, RSSI -70db
4/28/23 11:07:57 Updater: service started. Auto-update class is MINOR
4/28/23 11:07:57 Grid: Started
4/28/23 11:07:57 Grid: Last log entry 04/28/23 11:07:40
4/28/23 11:07:58 Updater: Auto-update is current for class MINOR.
4/28/23 11:08:02 PVoutput: started
4/28/23 11:08:03 PVoutput: System jayzPVoutput, interval 5, freeload mode  
4/28/23 11:08:03 PVoutput: Start status beginning 04/28/23 11:05:00
4/28/23 11:08:20 influxDB_v2: Starting, interval:10, url:
4/28/23 11:08:22 influxDB_v2: Start posting 04/26/23 01:00:10
4/28/23 11:08:22 influxDB_v2: stopped, Last post 04/26/23 01:00:00
4/28/23 11:08:31 influxDB_v2: HTTPS specified but no HTTPSproxy server configured, stopping.
4/28/23 11:08:31 influxDB_v2: Invalid configuration.

This is my uploader setup. I don’t fully understand everything about it yet but so I’ve duplicated several different posted setups that posters said were working for them. They all result in the same error shown above.

I’m running Influx on a local Linux Mint server. It appears to be working…both the CLI and GUI function without apparent errors. I can send data to it and view it via the CLI.

Running “curl -I” to it from a separate computer on the LAN gives:

HTTP/1.1 200 OK
Accept-Ranges: bytes
Cache-Control: public, max-age=3600
Content-Length: 534
Content-Type: text/html; charset=utf-8
Etag: "534473136"
Last-Modified: Tue, 04 Apr 2023 14:31:36 GMT
X-Influxdb-Build: OSS
X-Influxdb-Version: v2.7.0
Date: Fri, 28 Apr 2023 00:32:06 GMT

If I run this from either the non-host or host computer:

curl --request GET "" \
     --header "Authorization: Token z9Axxxxx-redacted-xxxxxxxxxxxfmQ=="

…I get:

	"links": {
		"self": "/api/v2/buckets?descending=false\u0026limit=20\u0026offset=0"
	"buckets": [
			"id": "82c609f1af91d49c",
			"orgID": "d77xxxxxxxxxxa95",
			"type": "system",
			"description": "System bucket for task logs",
			"name": "_tasks",
			"retentionRules": [
					"type": "expire",
					"everySeconds": 259200,
					"shardGroupDurationSeconds": 86400
			"createdAt": "2023-04-24T20:37:52.218100313Z",
			"updatedAt": "2023-04-24T20:37:52.218100587Z",
			"links": {
				"labels": "/api/v2/buckets/82c609f1af91d49c/labels",
				"members": "/api/v2/buckets/82c609f1af91d49c/members",
				"org": "/api/v2/orgs/d77xxxxxxxxxxa95",
				"owners": "/api/v2/buckets/82c609f1af91d49c/owners",
				"self": "/api/v2/buckets/82c609f1af91d49c",
				"write": "/api/v2/write?org=d77xxxxxxxxxxa95\u0026bucket=82c609f1af91d49c"
			"labels": []
			"id": "c1980879f12d332e",
			"orgID": "d77xxxxxxxxxxa95",
			"type": "user",
			"name": "iotawattBucket_1",
			"retentionRules": [
					"type": "expire",
					"everySeconds": 0,
					"shardGroupDurationSeconds": 604800
			"createdAt": "2023-04-27T23:56:39.350608311Z",
			"updatedAt": "2023-04-27T23:56:39.350608527Z",
			"links": {
				"labels": "/api/v2/buckets/c1980879f12d332e/labels",
				"members": "/api/v2/buckets/c1980879f12d332e/members",
				"org": "/api/v2/orgs/d77xxxxxxxxxxa95",
				"owners": "/api/v2/buckets/c1980879f12d332e/owners",
				"self": "/api/v2/buckets/c1980879f12d332e",
				"write": "/api/v2/write?org=d77xxxxxxxxxxa95\u0026bucket=c1980879f12d332e"
			"labels": []
			"id": "f0e9e1fa9e7af305",
			"orgID": "d77xxxxxxxxxxa95",
			"type": "system",
			"description": "System bucket for monitoring logs",
			"name": "_monitoring",
			"retentionRules": [
					"type": "expire",
					"everySeconds": 604800,
					"shardGroupDurationSeconds": 86400
			"createdAt": "2023-04-24T20:37:53.010131217Z",
			"updatedAt": "2023-04-24T20:37:53.010131384Z",
			"links": {
				"labels": "/api/v2/buckets/f0e9e1fa9e7af305/labels",
				"members": "/api/v2/buckets/f0e9e1fa9e7af305/members",
				"org": "/api/v2/orgs/d77xxxxxxxxxxa95",
				"owners": "/api/v2/buckets/f0e9e1fa9e7af305/owners",
				"self": "/api/v2/buckets/f0e9e1fa9e7af305",
				"write": "/api/v2/write?org=d77xxxxxxxxxxa95\u0026bucket=f0e9e1fa9e7af305"
			"labels": []

…which at least shows me Influx is running, if perhaps not 100% correctly…

But my question is:

Why can’t I get the IotaWatt uploader to function? Why does it tell me “HTTPS specified but no HTTPSproxy server configured, stopping.”…?


I’m not sure what’s going on here, but I think it may be a compound problem. First, I don’t see any way that the HTTPS message can be generated with the URL that you show in the post. That said, I can’t explain some other things as well. What gives me pause is that the influx setup that you posted does not have the save button active, so I can’t be sure that represents what is actually in your config file.

Can you download the config.txt file and upload it to me in a private message please?

The missing Save button is an easy one…I obfuscated the Organization ID with some random "x"s before screen shooting it, so the save button disappeared. The Save button us normally present and accounted for.

Will do. Am starting a weekend trip at the moment, will try to do it from the road or as soon as I get back.

I’m using Influx v2 but don’t recognize the “…/api/v2” at the end of your URL config. I don’t use that in mine and it uploads at least a few weeks of data before snagging on something else ( SD issue? too much data when backtracking into a brand new bucket?)
I also mis-selected the influx bucket ID (also 16 hex chars) instead of the influx Org ID, although that might give a different error.
My guess: if IotaWatt uploader knows about “/api/v2” it would append it automagically because it knows I have V2 and not V1 … right?

Yes, it will work both ways.