Influxdb password max and Corlysis

Hello,

I am a new to IotaWatt, and wanted to to some experimentation with Influxdb. I was looking around for a quick hosted Influxdb/Grafana service, and found Corlysis.com which offered a service (with a free tier) which looked like a good place to start.

Unfortunately, they assign a 32char password for Influxdb (not changeable), and Iotawatt supports a max of 16char. Am I missing something? Or is this just an incompatible intersection of fields defaults.

I’d also be open to any other reasonable priced hosted Influxdb/Grafana service if anyone has had success elsewhere.

Thanks,

-JR

Let me look into that limitation. It may be fairly easygoing to extend to 32 characters.

Looking at the code, the password length is arbitrarily restricted to 16 characters. The firmware in the IoTaWatt does not appear to have any restriction, it is enforced only in the configuration app. If you tell me what release you are on, I can make a two line modification to the configuration app to accept up to 32 characters.

That would be great, Thank you.

I am on IoTaWatt 5.0, Firmware version 02_04_02

Give this a try index.htm (105.8 KB)

Upload instruction is here http://docs.iotawatt.com/en/02_04_02/fileManager.html#uploading-files

I did not test this extensively, but it is simple and straightforward. Let me know if it works for you.

BTW/ Be sure to reload the config app after you upload, otherwise you will still be using the old version.

1 Like

That worked for the long password. Thank you.

Now I am on to the next hurdle.

1 Like

I tried that service. Problem is HTTPcode 400, {“error”:“missing required parameter “q””} .

The owners of the site don’t seem active. At least they are not responding to emails.

I had the same experience. Tried to contact them to work out this issue but no response.

I think they run a pre 1.0 influxdb. I remember having frequent “missing required parameter “q”” issues some years ago.

I’m having that issue as well.

I’ve contacted Corlysis support and invited them to help us here in this thread.

They don’t allow POST queries.

Could someone provide me and example of the URL, HTTP method that IotaWatt is using to send (POST) data to Influxdb.

I have one of the support people a Corlysis requesting this info.

Thanks.

-JR

Trying to get that, but need to know the port to send a HTTP request to. They seem to be requiring HTTPS on 8086 now.

They still support http://corlysis.com:8087 as far as I can see.

Thanks.

I sent a POST request to

HTTP://corlysis.com:8087/query

The payload was

db=iotadb&epoch=s&q=SELECT LAST(value) FROM voltage WHERE unit='iotatest'

The user and password were base64 encoded in an authorization header.

What I get back is:

{"error":"missing required parameter \"q\""}

They block POST query for some reason.

Writing data is no problem:
http://corlysis.com:8087/write?precision=s&db=iota
with payload:
Volt value=222.63 1574040350

It’s probably more a case of not supporting it than blocking it. I’ll see what happens if I send the query as a GET.

No joy.

corlysis.com:8087/query?u=token&p=99b3a056e68f3dc9d68006c092fa93a6&db=iotadb&epoch=s&q=SELECT%20LAST(value)%20FROM%20voltage20WHERE%20unit=‘iotatest’
HTTP code: 400,
{“error”:“missing required parameter “q””}
11/18/19 22:11:50 influxDB: Last entry query failed.

This is the URL that I sent with a GET.
At first I got invalid URL so had to replace all the spaces with %20
Then I got authorization failed, so moved the auth from the influx header method to the URL
Now back to the missing “q” which is clearly there.

These changes were just hacked into the code, and there would be issues with changing to do it this way, but I suspect the post was working OK and this q problem is something else. Pass it along to their tech and if there is any response, fill me in.

These changes are just hacked in, and would

yes, that would not work.

curl works:

curl -G ‘http://corlysis.com:8087/query?db=iota&epoch=s’ -u token:a0exxxxxx --data-urlencode “q=select * from Volt”

Many GET configuration ignore content headers. These guys explicitly seem to want:
–data-urlencode

HTTP GET with a Content-Type = application/x-www-form-urlencoded header won’t work the same (somehow…)

Hi, I am Corlysis Co-founder.

  1. we support HTTPS (https://corlysis.com:8086) and also not secured HTTP (http://corlysis.com:8087)

  2. do insert data by HTTP POST request e.g. “”
    curl -i -XPOST 'CORLYSIS_URL/write?db=your' -u token:12456 --data-binary "meas_test,place=garden value=20.64"

  3. do query data by HTTP GET request (Influxdb supports also HTTP POST but we dont) e.g.:
    curl -G 'CORLYSIS_URL/query?db=emon' -u token:AABBCC --data-urlencode "q=select last(value) from Volt"

  4. our users send data to the Corlysis from e.g. Sigfox IoT service without any issue. e.g. URL: CORLYSIS_URL/write?db=yourDB&u=token&p=YOUR_CORLYSIS_PASS and text plain data e.g. “meas_name val=55”

  5. in this chat there is strange rule that I cannot send more than 2 links so sorry for strange