Inputs not working at all - RESOLVED


Receiving my package before christmas seemed to be awesome. Just wanted to hook it up and see what the devices would do over christmas. But, having followed the Manual (Plugged USB Power supply & AC Transformer into a wall socket) to get things working, i dont get any input readings. I also defined the inputs by the SKU on the Packing Slip.


I dont see any errors in the message log, other than power failure detected (?? after a restart it doesnt show up):
SD initialized.
12/24/19 17:23:45z Real Time Clock is running. Unix time 1577208225
12/24/19 17:23:45z Power failure detected.
12/24/19 17:23:45z Reset reason: Power on
12/24/19 17:23:45z ESP8266 ChipID: 6144648
12/24/19 17:23:45z IoTaWatt 5.0, Firmware version 02_05_02
12/24/19 17:23:45z SPIFFS mounted.
12/24/19 18:23:46 Local time zone: +1:00
12/24/19 18:23:46 device name: IotaWatt
12/24/19 18:23:49 Connecting with WiFiManager.
12/24/19 18:23:52 MDNS responder started for hostname IotaWatt
12/24/19 18:23:52 LLMNR responder started for hostname IotaWatt
12/24/19 18:23:52 HTTP server started
12/24/19 18:23:52 WiFi connected. SSID=[Redacted], IP=, channel=2, RSSI -57db
12/24/19 18:23:52 timeSync: service started.
12/24/19 18:23:52 statService: started.
12/24/19 18:23:52 Updater: service started. Auto-update class is MINOR
12/24/19 18:23:52 dataLog: service started.
12/24/19 18:23:52 dataLog: Last log entry 12/24/19 18:23:35
12/24/19 18:23:52 historyLog: service started.
12/24/19 18:23:52 historyLog: Last log entry 12/24/19 18:23:00
12/24/19 18:23:54 Updater: Auto-update is current for class MINOR.
12/24/19 18:27:31 Restart command received.

I tried multiple inputs, 0 giving me any data. I hope im doing something wrong, but i can’t seem to find a topic on this forum with similar conditions. Can you help me out?

This is a first.

I know this sounds crazy, but can you first see if the stereo jacks on the CTs are plugged in all the way? It’s unlikely that is the problem with all three, but just to check that off. There have been a couple of CTs where the plastic jacket around the plug extends over the metallic jack and inhibits full insertion. Again, unlikely all three but just to check.

The next thing I’d like to try is to configure inputs 13 and 14 as VTs using the same Ideal 77DE-06-09. Then move the AC reference from the input zero to each of the three-phase voltage inputs marked 13 and 14, noting what the status display shows as you do that.

Thanks for your fast reply. Not crazy at all. To ensure you they have been plugged in correctly i snapped a quick picture with my smartphone.

I also configured inputs 13 and 14 as requested and screenshotted them.

Input 13:

Input 14:


That channels 13 and 14 work fine as voltage channels tells me that the bias circuits are working fine and that both of the ADCs are working fine. There isn’t really anything else within the IoTaWatt that could be causing this, so that leads me to question if the CTs are correctly installed.

Is it possible you are clamping them around both conductors in a circuit, such as around a power cord to an appliance? CTs must be clamped around only one of the conductors in a circuit.

If the CTs are on a single conductor, is it possible those circuits are currently using 0 Watts?

I sir, am an total idiot. I did read, but not far and thorough enough. Thank you very much for your time and support.


Glad it worked out. You are not the first one to make this mistake. Happy Holidays.

1 Like