Iotawatt issue uploading data to emoncms since last week

Hey Guys,

I’ve had the IoTaWatt posting to emonCMS for almost a year now, and last week we had a power outage and the data has not been able to be recorded on emonCMS since. I’ve tried restarting it several times.

I can, however, see from the local device (http://iotawatt.local/) that it is running/recording:

I’ve tried setting the “upload history from:” to a month ago in settings and no change.
Here is what the Message Log looks like:

** Restart **

SD initialized.
9/30/18 21:46:10z Real Time Clock is running. Unix time 1538343970
9/30/18 21:46:10z Version 02_03_13
9/30/18 21:46:10z Reset reason: Software Watchdog
9/30/18 21:46:10z Trace: 1:4, 1:5[21], 1:6, 1:3, 1:4, 1:5[14], 14:0, 14:4, 1:6, 1:3, 1:4, 1:5[19], 1:6, 1:1[8], 1:2[9], 9:0[9], 9:0, 9:1, 8:4, 8:6, 8:8, 9:3, 9:4, 9:5, 9:9, 1:2, 1:3, 1:4, 1:5[3], 3:0, 3:6, 3:6
9/30/18 21:46:11z ESP8266 ChipID: 416960
9/30/18 21:46:12z Local time zone: 0
9/30/18 21:46:12z device name: IotaWatt, version: 3
9/30/18 21:46:12z MDNS responder started
9/30/18 21:46:13z You can now connect to http://IotaWatt.local
9/30/18 21:46:13z HTTP server started
9/30/18 21:46:13z timeSync: service started.
9/30/18 21:46:14z statService: started.
9/30/18 21:46:14z WiFi connected. SSID BELL482, IP, channel 11, RSSI -44db
9/30/18 21:46:14z Updater: service started. Auto-update class is MAJOR
9/30/18 21:46:15z dataLog: service started.
9/30/18 23:11:50z dataLog: Last log entry 9/28/18 06:33:25
9/30/18 23:11:52z Updater: Auto-update is current for class MAJOR.
10/01/18 13:11:51z timeSync: adjusting RTC by -1
10/02/18 03:12:54z timeSync: adjusting RTC by -1
10/02/18 16:12:54z timeSync: adjusting RTC by -1
10/03/18 06:13:57z timeSync: adjusting RTC by -1

Thanks, help is appreciated !!

There have been ongoing problems with the high resolution current log. I don’t know the source of the corruption. There is a new release - 02_03_16 that I have just made current for MINOR and MAJOR auto-update. That release should get your system going again. It will seem to hang for an hour or so after restarting with RED-GREEN-RED sequence on the LED indicating that the damaged current log is being analysed and a diagnostic file produced. After that, the current-log will be deleted and the unit restarted.

The history log will still be intact with 60 second resolution data up until the time of the failure. Your message log posted above indicates that may be 9/28.

Based on reading other posts I tried using:

The information is posting to emonCMS again, but the log shows:

10/06/18 19:36:18z Updater: Update from 02_03_13 to 02_03_16
10/06/18 19:36:18z Updater: download 02_03_16
10/06/18 19:36:33z Updater: Download failed HTTPcode
10/06/18 19:36:35z Updater: Update from 02_03_13 to 02_03_16
10/06/18 19:36:35z Updater: download 02_03_16
10/06/18 19:36:51z Updater: Download failed HTTPcode
10/06/18 19:36:53z Updater: Update from 02_03_13 to 02_03_16
10/06/18 19:36:53z Updater: download 02_03_16
10/06/18 19:37:09z Updater: Download failed HTTPcode
10/06/18 19:37:11z Updater: Update from 02_03_13 to 02_03_16
10/06/18 19:37:11z Updater: download 02_03_16
10/06/18 19:37:26z Updater: Download failed HTTPcode

I’m regretting doing: http://iotawatt.local/command?deletelog=current
Looks like the data since it last posted to emonCMS is not showing, I wasn’t sure if it would delete the data.

The “History log” still has lots of data - would this be the input data that can be posted/recovered?

The data just wasn’t there. I know it looked as if your system was running, but it wasn’t recording the data in the log or sending it to Emoncms. The sooner the damaged log was deleted, the sooner a new log could be created.

What is going on now is that it’s taking a very long time to format the gap in the history log. The problem looks to be compounded by the repeated attempts to download the new release. I would suggest that you set auto-update class to NONE until the ending date/time of the history log matches your current log, then set back to MAJOR or MINOR to download the update.

Are you saying my kwh accumulators will fix themselves?
or do I need to delete/reset them? they are giving crazy negative numbers

It looks like the IotaWatt is working again, but yes, your kWh feeds appear to be corrupted. Not sure of all the remedies in EmonCMS but one solution is to delete those feeds.