Iotawatt red led

changed the position of my iotawatt, restarted, stuck in red led like there is no WiFi connection. unplugged everything and put the iotawatt next to the access point… same red led. checked in my router and in my WiFi ap and the device isn’t connected, so it’s impossible to do any command to the device. any idea? any way to do a factory reset? thanks in advance

You should see a RGG led pattern for the first three minutes after powering it up. Can you verify that or tell me what you see at that time?

only red led… i have also changed the 5v power supply, nothing changed! if you want i can make you a video (very boring video :blush: )

Solid red or blinking (once per second) or rapid blinking (more of a dull glow)?

solid red, not blinking

Do you have the AC adapter connected?

with ac adapter connected and not connected same result.
maybe my 9v is broken?

I doubt it.

You say this happened after you moved the unit. Presumably it was working before the move, and not after the move.

You also don’t specify whether the new location is serviced by the same SSID and password, so I’ll assume it is.

Also, no mention of other behavior before this solid red condition, so I’ll operate under the assumption there was none.

Solid red is not a known failure mode. I’ve seen a very dull red after the ESP8266 fails to flash, but that’s not what is described here.

All I can do for you at this point is fix it. When did you buy it and do you know the order number? Also, are you in the USA or Canada?

correctly working for almost 3 years with 0 issues (order 1201 from italy), power of the iotawatt, move my electric panel and after a week i reinstall the iotawatt with the same setup.
maybe one week off can cause something?
the new position is more close to the ap, which have obviously the same ssid;
on configuration panel of the ap (ubiquity ap lr) i can’t see iotawatt.
just simply power off, unplug, move, reinstall.
if the 9v is unplugged, the device can start correctly?

No, unplugging the 9VAC should not cause this.

The only way to field reset the unit is to flash it. That stands a good chance of reviving it. Flashing is done with a python program called ESPTOOL. There are a lot of different ways it can be used and configured for different platforms. I will leave it to you to determine if you can do that and research how to install python and the ESPTOOL program. I can provide the firmware .bin file, do you know what auto update class you are?

If you are not able to flash it, I can do it for you but you would need to send it to me in the USA.

no problem flashing the unit, i have plenty of esphome device (mostly nodemcu 8266 used with home assistant and flashed with the dedicated plugin, very easy procedure)
i have already download latest pyton and used this command to install esptool: pip3 install esptool
i got this: WARNING: You are using pip version 21.2.4; however, version 21.3.1 is available.
You should consider upgrading via the ‘C:\Users\Oo\AppData\Local\Programs\Python\Python310\python.exe -m pip install --upgrade pip’ command.
upgraded with this command.
connected the device to my pc trough usb and it reconize as Silicon Labs CP210x USB to UART Bridge (COM3)
on the back of the device i can read model w14
tell me if i did wrong something.

do you know what auto update class you are?

no

sent pm with my email address for the bin file
please tell me the procedure to flash (never done with esptool)

on the back of the device i can read model w14

IoTaWatt is the same. It uses an ESP8266 nodeMCU which has a CP2110 USB interface. So you appear to be almost there. You just need to look at the documentation for the ESPTOOL that you have and run it specifying to flash, the USB port, and the firmware file to use.

do you think i can flash the bin file like i do with the esphome?

I’ve not used ESPhome. IoTaWatt is an ESP8266 nodeMCU. You can Google it and work it out, or you can send it to me and I’ll do it.

tried to flash the bin file with:

esptool: esptool.py --chip esp8266 --port COM3 write_flash --flash_mode dio --flash_size detect 0x0 iotawatt.bin
esptool.py v3.2
Serial port COM3
Connecting…

A fatal error occurred: Failed to connect to ESP8266: No serial data received.
For troubleshooting steps visit: https://github.com/espressif/esptool#troubleshooting

esphome flasher: Unexpected error: ESP Chip Auto-Detection failed: Failed to connect to Espressif device: Timed out waiting for packet header

nodemcu firmware programmer: error, not loading the firmware

the device is correctly connected to my pc (com3), when i try to upload the firmware the led is blinking from dull to solid red like is receiving something but apparently not in the right way.
quick solid blink > dull > 1 sec solid blink > dull and again until fail

update also the usb to uart drive

any ideas??? :face_with_head_bandage:

It was worth a try. At this point all I can do is offer to repair it.

now i got green-red-red after removing the sd card!!!
so i think the sd card is the real problem, now i try to find a sd in my house and replace
i’ll update later

wich files have i to put in the sd? is it the folder called SD on this git? https://github.com/boblemaire/IoTaWatt

UPDATE: device up and running, just for information i have an esp-12S
thanks overeasy

1 Like

I just hit the same problem. The device just lost connection and now I have a dull solid red light. I did not move it or anything. I got it a couple of weeks ago and it’s been running fine. I know wifi is working. I did try to power cycle but all I get is the solid dull red light.

Should I follow the same troubleshooting steps removing the SD card? If I do I assume I will be able to connect to wifi without the SD card. Or do I need to flash a new one before I know it is the SD card.

Before I try a different SD card and follow the same procedure:

  1. Where do I find the iotawatt.bin file?
  2. Where do I put the files from git folder SD on a new SD card?
  3. What flash utility do you recommend?

Thanks for help!

I’m not convinced it’s the SDcard, but feel free to try removing it and reinserting. Always do it while the unit is powered down.

BE VERY CAREFUL NOT TO BREAK THE CARD. It’s very brittle. You need to pull it straight out carefully and gently. It helps to lift the PCB and pull gently with needle nose pliers.

The card itself is probably ok. If you decide to replace it, you should be able to just copy it.

If you want to send it in, I’ll be happy to test and fix anything I find.

Well, this was weird. I tried a different power supply and got the green light. Went back to the original one in the same location and it is working. Maybe it was not fully plugged in. I don’t know - I did reconnect it once before and still had the dull solid red light.

Not really sure what the issue was but it is back working again…

1 Like