IoTaWatt Web GUI Not Loading Correctly

It’s been working fine for me for the past 2 days, but, today, after getting home from work, I thought I’d log in to check things out. The GUI is taking a very long time to load and I end up with a screen like this where the buttons are completely non-responsive:

I’ve tried the Shift+Click Reload trick to completely refresh the page in both Chrome and Firefox, but it’s still not loading correctly. In Chrome, it came up with the normal 4 green buttons screen, but the buttons were still non-responsive. It’s almost like the web server isn’t fully serving up the page. Going to give it a power cycle in a minute if it remains this way. But would be great to have an idea what the issue might be.


Yeah, I just inspected the main page that’s returned (which took 30 seconds), and the JavaScript at the bottom isn’t fully finished yet. The page load is being interrupted for some reason.

Pulling the power on the USB power supply and reconnecting a few seconds later solved the issue. Fully responsive again. However, I’d like to know how I caused this to happen, if in fact it was something I did. I’ve been doing quite a few Graph+ graphs while tracking my other support issue of noise on my CT lines, so I don’t know if there is some Graph+ state that is not being cleared from the web server or what. I’ve been closing my browser when I’m done with stuff, so this isn’t one long continuous browser session or anything.

I had this issue and it turned out the wifi signal to the device was very weak.

My thread