iotaWatt will not connect to wifi with muliple ASUS mesh APs

I have 1 main router along with 2 AP routers. Each has a 2.4ghz ssid defined using the same name/password but different channels. When I try to setup my wifi connection I select this ssid, enter the password and continue. The new pages states the configuration has been saved and hangs at this point. There are no error messages.

I have a garage router with a ssid which has both a different ssid name and channel (but same password as above). Using this ssid during the wifi setup and all is good. The hub LED turns to a dull green. Using this connection is not desirable as the signal may be weak once I install the iotawatt at it intended location in my house. I therefore disconnected this connection.

I decided that I would rename the ssid on one of the AP routers and try to connect to it. No problem connecting but this now means I have 2 unique named ssids one of which is only needed because I could not connect the iotawatt to my wifi otherwise.

I have never accounted this problem before with all my wifi devices I have connected. I would prefer to go back to a 1 name only SSID for my neywwork. Is this possible?

I don’t know what you mean by 2 AP routers. The IoTaWatt must be on the same LAN as the browser trying to connect. Two routers with the same SSID and password are not necessarily on the same LAN.

I have a Unifi router with four wired access points. The APs each use a different channel but are on the same LAN because they all connect to the router that contains the DHCP server. As you can imagine I have a lot of IoTaWatt running all over the place, yet I can connect using mDNS to any of them from anywhere.

In my case they are.

Same here except mine are ASUS routers.
Main router :

Garage: same LAN with different SSID name/channel

I have 10 wifi cameras connected to the LAN which all use this same SSID. If I shutdown any of the (in house) AP to which one or more cameras are connected to, no problem. They just connect to the available AP (or main router). This is the case with all my wifi devices such as Wemo, Ring doorbell,etc

When I setup any of these devices I selected the desired SSID without any regards to which AP it would connect

I removed the IotaWatt from my lan, renamed the SSID back to its original name and started over.
As a workaround I turned off all 2.4ghz radios except on the AP router closest to where the iotawatt will be installed. I was able to connect to the one remaining SSID and got access via a web browser. I then turned on all the 2.4ghz radios and so far so good. The IotaWatt still appears connected and hopefully stay that way. I’d feel better if I knew it will remain this way

I’m working with limited information here, but it sounds like you have each of the ASUS routers is actually a subnet off of the main router. I’d be curious to see if the “AP” routers have a DHCP client list.

Your browser connects to IoTaWatt using a protocol called mDNS or multicast Domain Name System. The way it works is that when you specify “iotawatt.local” your browser send a broadcast datagram to all of the devices on the local network. The datagram essentially requests any device answering to that name to identify itself. IoTaWatt listens for these broadcasts and will respond with its IP address. Your browser will save that information and use it to communicate with iotawatt.local in this and subsequent communications.

If you "AP"s are actually routers connected to the main router, any datagram broadcast will only go out to the devices connected to that “AP”. If the IoTaWatt is connected to a different “AP”, it will not receive the broadcast. You can’t get there from here.

I don’t know how your ASUS routers are configured, or if they can actually work as true APs to the main router, but it doesn’t sound like it. Your recent experiment reinforces that.

As far as I understand, consumer routers don’t play together the way a commercial router and APs do. One test would be if you have a printer on AP1 or AP2, can you find it from the other?

Nope… for AP routers, no subnet, no DHCP client list. My network is pretty simple and I am not sure what more info I can provide. Below are a few screenshots of 3 of the routers. Sorry for all the post. Would not allow me to post more than 3 pics in one post




Searching for “ASUS mesh mDNS” I can see several issues relating to inter-node mDNS. As usual some of these are older and some are newer, and they reference various firmware releases. Safe to say that since you report no issue when the browser and IoTaWatt are in the same node, this probably has something to do with inter-node mDNS.

Not anything I’m inclined to investigate further. I’d suggest you assign a static IP to the IoTaWatt and use that to access.

All my wifi devices use static IP.

I thought I had resolved my issue by turning off all but one 2,4 radios and connecting to the remaining ssid. That seemed to work even after turning all radios back on. In fact, I then decided to turn off the radio to which iotawatt initially connected to see what would happen. As with all my other devices, it simply hopped onto one of the other radios. As I am still experimenting, I turned the IotaWatt off for the night.

This AM I turned the iotawatt back on and watched as the LED flashed from green to red for 1+ minute(s) then turned a solid red. It was no longer connected to my WIFI.

I think the issue is related to the channel numbers. I changed all my 2.4ghx radio from static channel number to auto and viola… It worked however once I rebooted the iotawatt the wifi connection was gone. I am now back to using one unique SSID specifically for the Iotawatt. Not impressed.

OK so an old thread - but a couple of things

  1. This is not a mesh setup - this is a multi access point wireless network
  2. I used to run exactly this with these same units until recently when i replaced them with TP-Mesh (Proper Mesh) units.
  3. By putting these devices into AP mode you essentially treat them as a bridge between the Wireless network and the Wired network so they provide no DHCP or other features.
  4. I used to run mine wih an alternate firmware (Merlin)
  5. You need to make sure that your 5Ghz and 2.4Ghz Wireless networks have a different Name or the IOTAWATT will have issues.

There were a couple of other tweaks i had to do to get everyting stable - note this was not restricted to just IOTAWATT - anything else that had an ESP8266 also randomly had issues


That is what I ended up doing.

I run both my networks with the same SSID and have no issues with Iotawatt.

It very much depends on what you are using (manufacturer) and whether you are doing a mesh network or a multi AP network.

We have just renovated our house and put smart bulbs into the kids bedrooms - they would not connect to our TP-Link M5 mesh network until we disabled 5Ghz - once connected they were then fine to operate with the 5Ghz turned back on.

Our old Google home will not connect at all to the TP-link Mesh


I hear you. FYI, I have used Iotawatt with Nest mesh router in the past and now use the TPLink AX3600 mesh router. Never had an issue with connecting with both routers having 2.4Ghz and 5Ghz networks turned on.