Is my VT reference busted? (Yes it was)

Hi Team,
Just installed my IotAwatt on Friday in Melbourne, Australia - Single Phase, with help from sparky cousin.
I bought the recommended VT transformer from Jaycar for us aussie’s - the Powertech MP-3027
and configured the input as such.

However i have no noticeable Watts being measured.

I’m thinking either the transformer is faulty (it was dropped during installation) or perhaps the input plug (as i’ve just read in another post in the forum (handy feature that, when posting to show me another post that may be the same)).
When I jump to Graph+ i can see the Amps for mains supply and solar, and when i check volts it is only in the range of 0-.3V.

What else can i check to determine what might be at fault? and what else can i post/upload to help diagnose the problem?

Thanks In advance (love the product btw!)



Hello Angus,

You seem to be on the right track. The voltage should be showing up in the status display. Do you have a meter that you can use to check the output of the transformer?

If not, you seem to only have 13 of the 14 power inputs configured, so if 13 or 14 is available (no CT plugged in) you can plug the VT into the corresponding three-phase plug (they are numbered 13 and 14) and then configure that channel as a VT and the Jaycar model.

If you then see voltage for that input, the VT is working and there is a problem with the IoTaWatt input, if it shows zero, it’s probably the VT.

Thanks for the response overeasy.
i have just tried as you suggested changing the VT down to input 14 and configured the input to match. still get nothing.
I will get another transformer and try again :slight_smile:

Will update when i get it resolved.


1 Like

Just to be clear, this was a diagnostic procedure. It would not have made the other inputs start working, just show voltage on input 14. If 14 is zero, then it is most likely the VT.

did you manually test the transformer with a voltmeter? (I use the same). And did you set it in the inputs?

(note that I have 3 phases)

Hey Team, don’t have access to a voltmeter easily, it’s on the buy list, but i was going past jaycar so grabbed another transformer and viola!

So thankyou for the help team.

Look forward to setting up some emoncms or influx - one better/easeir then the other?


1 Like