Not getting config page

I received my IoTaWatt over the weekend and would like to thank you for the prompt shipping. One small problem was that the plastic case of the voltage transformer was busted open but everything looked to be intact and it seems to be working correctly.

However, I am having a problem with the setup procedure. On power-up the IoTaWatt does appear as an access point, blinks the correct red-green-green code and my computer does connect to it but then it takes a very long time for the ip address to to show up in the connection status window. When it finally is assigned an ip address the type is an “Automatic Private Address” and the address is with a subnet mask of No configuration page is ever displayed. Also, at some point the blink code changes to red-red-green.

Do I need to enter an ip in the address bar or something in order to get to the configuration page?

Thank you for your work on this project and your assistance,


Sorry about the VT. I don’t open the boxes to inspect them, but if there is any problem at all, I’ll be happy to replace it.

With the captive portal setup, can you tell me what device you are using to setup the WiFi? In general IOS devices work well. I believe the IP address of the AP is, so if you are able to connect to the AP but don’t get the captive portal screen, try browsing to that IP address.

The red-red-green means that WiFi is not connected and the real time clock is not running, so it should stay in AP mode indefinitely.

Thank you for the quick reply

I had been using my windows laptop for the configuration but after reading your reply I tried using my android phone with the address and that worked to get it configured and connected to my wifi network.

Even after it was connected I could not access it using “http://iotawatt.local” and had to look it up in my router’s device table to find the right ip address.

Earlier it was uploading data to PVOutput but I must have screwed something up because it no longer updating.

Thank you again for your assistance,


Good that you got connected. Fortunately, that’s something that you only need to do once. With all of the platforms and browsers around the world, it would be a huge effort to write software to do this. I rely on a package called wifimanager to do this. There are issues but it generally works, and like I said, you only need to do it once.

The problem with accessing using iotawatt.local is usually a problem with a firewall or path settings in windows. The way it works is that Iotawatt listens for a broadcast of that name and responds by sending its IP address to the sender. When it doesn’t it’s typicallythat the broadcast or response is blocked. So the IP is a fallback.

If you continue to have trouble with PVoutput, please post the message log and I’ll take a look at what is happening. That has been a very solid service and should backfill the history when it gets going again.