One of two Iotawatts is flakey Resolved

I’m in the USA, on 240V split-phase service, with two Iotawatts mounted in a box about 6 inches apart monitoring each circuit that I have individually. They share a common 5V USB power supply via a soldered splice, and they share a 9VAC transformer via a “y” cable.

I replaced one of the two Iotawatts hoping to solve this issue, but the new one is showing the same kind of behavior, so I’m guessing that there’s something about my setup that’s causing issues. And, like most flaky issues, there are lots of symptoms, most of which are probably red herrings.

So, what I’m seeing is that after running perfectly fine for “awhile” (several hours, but less than a day), the first of the two Iotawatts (let’s call them Iotawatt_A and Iotawatt_B)will stop responding when I try to communicate via a browser. So, some possibly red-herring symptoms:

  1. If I leave the browser open on one of the Iotawatt_A pages before it dies, I can navigate to some other pages (but not all). I think this is an artifact of the HTML and browser caching, though, and not the Iotawatt actually responding.
  2. If I try to create a new connection to Iotawatt_A, the browser doesn’t fail to connect to the Iotawatt - I just get a spinning wait indicator. Perhaps the Iotawatt is alive enough to create a TCP connection, but not alive enough to respond to the HTTP query?
  3. If I leave the browser open to the “Status” page, I can notice that the “AC Cycles sampled / sec” drops from it’s normal ~39 to 0.
    3a. Playing with the 9VAC transformer recovers the unit when it’s in this mode. Disconnecting/reconnecting the 9V jack makes it happy, unplugging/plugging the Xfmr makes it happy, disconnecting/reconnecting the 9V jack on the OTHER iotawatt makes it happy.
    3b. The Iotawatt will eventually become non-responsive again.
  4. If I leave the browser open to Graph+, I can see that the Iotawatt stops sampling - all of the graph lines go flat at their last valid values. (See attached; the graph shows the iotawatt stopped taking data about ~1:45 AM, and the log shows the iotawatt resetting 6:56 AM. The graph doesn’t show the Iotawatt taking data after 6:56, until I power-cycled at 8:28 AM). The other Iotawatt was happy during this period.
  5. This all worked fine a year ago when I originally installed, although there were occasional, similar hiccups with the old Iotawatt_A that got more frequent.

So, the question is, where’s the problem?

  1. The shared 5V supply might be a problem. How much current does the Iotawatt pull?
  2. The shared 9VAC might be a problem. If it fails, the “AC Cycles Sampled” goes to zero, which I can understand, but it shouldn’t cause the unit to become unresponsive. I’ve replaced the original Y cable I got from you with one I built, and the same problem occurs. Maybe I’ll gin up something that let’s me externally measure the 9VAC when the unit stops sampling.
  3. The units being physically close together might be a problem - EMI from one causing problems with the other, but this seems really unlikely to me.
  4. Any other thoughts?


Iotawatt_log.txt (9.9 KB)

With something like this, I like to take it one thing at a time. So let’s look at the basic setup.

I have repaired several units that were connected in tandem because of issues. Essentially while not recommended, , it’s ok to have the AC polarity off as long as the units don’t share a common.ground. In your case, the shared power supply does introduce a common ground. So that’s a good reason to use two separate USB power supplies.

The ESP8266 uses a greatly varying amount of power. Not much most of the time, but quite a bit when transmitting. A second good reason to use two separate USB power supplies.

So you can see that I’m a big fan of separate power supplies. Could you spring for another one and report back the results?

The ESP8266 works hard in the IoTaWatt. It is sampling the ADCs 66% of the time. The rest of the time it does everything else, like run a web server to talk to you.

The heartbeat of that time slicing is the AC signal. Without that, the scheduler has no reference to switch between sampling power and everything else. So when you associate AC with your problems, it makes sense to eliminate any potential AC issues.

Final question. Do these units run without issue when the other is disconnected?

Thinking about your final question, I don’t know that I ever disconnected Iota_B to see if Iota_A worked well. I’m running a test now with two separate power supplies; if it fails, I’ll try that.

I originally went with a single supply because I only wired two outlets into the box - and that gives me space for one 5VDC and one 9VAC supply. Maybe I’ll have to add on.

I’ll buy into a shared grounding problem of some sort; the weirdness around the 9VAC supply kinda points in that direction. It’s possible that the 5V supply has degraded over time, making the shared grounds more of a problem. The question, of course, becomes: How much shared ground is too much? Do I have to get duplicate 5V AND 9V supplies, or is just a 5V supply good enough? Is a two-port USB charger like: good enough, or should I really just bite the bullet and get two completely seperate chargers?

I’ll update this in a few days when I determine some more answers…

Don’t confuse chargers with power supplies. Maybe some chargers have clean power, but not many. A good power supply will have good voltage regulation and very little ripple. So if you are actually using a charger, that alone could be the problem. I have been using CUI switching supplies. SWI5-5-MUB which is 5W (1A).

Any path between the ground of the two units is too much if the AC is out of phase. Direct connection will fry the bias op-amp and possibly one of the TVS diode arrays. Both of the incidences that I have repaired caused complete failure, but you may have discovered a more subtle damage.

If you use separate supplies, you should be good, but belt-and-suspenders I would insure the AC is in phase. Easiest way to check is to see if there is a potential between the outer barrels of the plugs. If so, they are out of phase.

Well, I’ll disagree on whether a “USB Charger” is different than a “Power Supply with a Micro-USB connector”. After all, they’re both off-line switching supplies, although the “USB Charger” may have some additional circuitry to adjust it’s overcurrent protection (and Voltage, if it’s a QC3 charger) based on inputs from the external device. I will agree that many of the cheap USB chargers will likely have poorly regulated, noisy outputs, but that has less to do with their marketing name and more to do with “cheap”.

That said, I looked at the adapter I was using to supply both Iotawatts - a CUI SWI3-5-N-MUB. Yup, 5V @ 600 ma, probably insufficient (or barely sufficient in good conditions) for two Iotawatts. There certainly wasn’t any ground potential between the two iotawatts related to the power input, being as they were connected to the same supply.

Is there any connection between the 9VAC input and ground? I’m still a bit confused as to what could possibly cause the weirdness with the 9VAC, where disconnecting the working Iotawatt would cause the non-working one to recover. Once again, the two Iotawatten were connected to the same supply, with the outer rings connected together and the inner pins connected together, so there’d be no potential there. I was assuming that the problem was some potential or ground loop occurring between the 5V ground and the 9VAC input; looking at the schematic, I don’t see any obvious way for that to occur, though.

At this point, I’m pretty sure that using two separate supplies will solve my problems, but I don’t quite understand why. I don’t know that I’ll ever get an answer to that, either.

The AC signal is biased by a 1.65V DC (relative to ground). So as soon as you do that, the AC becomes relative to ground as well. If the two units share a common ground, you have a ground loop.

The bias comes out of the op-amp, so when the AC is out of phase, the op-amp fries.

1 Like

OK, I’m going to call this resolved, with a root cause of “User Error: sharing an insufficient power supply with two Iotawatts”.

After three days using separate 5VDC power supplies (still sharing the same 9VAC adapter), everything is working solidly, with none of the flakiness that I originally reported. I really appreciate the help, overeasy, and I’ll try to avoid doing such stupid things in the future.

1 Like