Password not working on Graphs tab - resolved


We setup a password for one of our units. As expected, when we go into the main page authentication asks for User Name and password. We can then access the unit normally.

However, for the Graphs tab (and apparently only that tab) the following happens:

  • When initially selecting the Graphs tab the page is displayed correctly.
  • Once one of the measurements is selected in its checkbox the authentication window pops up again and it won’t accept the user/pass anymore.
  • If we close the authentication window and go back to the main page the window pops up again, so it seems as if the session is being closed. I’m not familiar with authentication so it may be an obvious behavior.

I’m also attaching the most recent entries from the Message Log, basically what is displayed from the Tools menu tab.

MessageLog Latest on 20180810.txt (9.8 KB)

The Log includes the following error, which most likely is unrelated: “EmonService: Invalid configuration.” That’s most likely (I think) happening due to deleted inputs that are still listed in the Emon configuration window (everything named Input_XX).


It behaves differently on different platforms and browsers. What are you using?

Also, are you using both admin and user passwords? If so, could you try setting just an admin password? I can reproduce a similar problem when a user password is set.

If you are still getting this, could you post your config.txt file (w/o the Emoncms key).



We tested with Chrome and Firefox; same thing; it kept popping up the authentication window.

Days before this we tried to setup a User password but we were never able to login using it.

Anyway. It’s working now, but I don’t understand why. What I did: I went to Setup/Passwords, validated the Admin password, then reentered the admin password (so it remains the same) without typing anything at the User password box and it has been working since then. I don’t know if not entering a user password automatically deletes it, though.

Regarding the EmonService error I tried removing the now invalid inputs but the window never shows a save button, so I’m stuck with those. However, the service is not fully configured so it shouldn’t be a problem I guess. See the image below.

Edit: Forgot to attach the config file.

config file.txt (3.0 KB)

Yes, it does. The password menu sets both passwords. Leaving either blank removes it and you cannot set a user password without also setting an admin password. To remove all passwords, save that menu without specifying any passwords.

Your config file was damaged. I have fixed it. config file.txt (2.6 KB)

Thanks a lot.

So the error was related to the damaged file, not configuration.

Another thing: While I was again checking status, and still with an admin password but no user password I noticed that the Device Name text box in the Setup/Device tab was grayed out. I removed the admin pass and the field is now editable.


I’m including again the config file in case it is of any help.

config file 20180815.txt (2.6 KB)


That’s by design. with digest authorization, IoTaWatt doesn’t store the actual password, but a cryptographic hash of it that also includes the device name. When you enter the password, your browser creates another hash using the password, the device name, and some other things unique to the request. That way, the authorization is secure.

So since I don’t really know what your password is, I can’t save the new crypto If you change the device name. I force you to remove the password, change the device name, and set a new password.

I hope to get the time to document that (and fix the user led) soon.

So that’s why. Thanks !!!