Performance issues, super slow Web UI response

Since several months I have a problem that my iotawatt web interface response (in my local home network) is either super slow, or even times out before the whole web page can be built.

I first thought it was because of the load of an uploader, which I defined in the past for testing purposes. But after deleting that the system still is hardly responding at all.

Data collection still seems to work fine. When I manage to display some data, it seems correct.

I reset the Wifi connection and checked with a laptop and phone that the Wifi signal is strong in the room where the iotawatt is located.

Below is a log file of my latest reboot.

Any idea what I can do to troubleshoot this?


** Restart **

SD initialized.
10/03/21 00:19:21z Real Time Clock is running. Unix time 1633220361
10/03/21 00:19:21z Power failure detected.
10/03/21 00:19:21z Reset reason: External System
10/03/21 00:19:21z ESP8266 ChipID: 6148248
10/03/21 00:19:21z IoTaWatt 5.0, Firmware version 02_06_05
10/03/21 00:19:21z SPIFFS mounted.
10/02/21 17:19:21 Local time zone: -8:00
10/02/21 17:19:21 Using Daylight Saving Time (BST) when in effect.
10/02/21 17:19:21 device name: IotaWatt
10/02/21 17:19:24 Connecting with WiFiManager.
10/02/21 17:21:13 HTTP server started
10/02/21 17:21:13 WiFi connected. SSID=2768-Ortona, IP=, channel=6, RSSI -73db
10/02/21 17:21:13 MDNS responder started for hostname IotaWatt
10/02/21 17:21:13 LLMNR responder started for hostname IotaWatt
10/02/21 17:21:13 timeSync: service started.
10/02/21 17:21:13 statService: started.
10/02/21 17:21:13 Updater: service started. Auto-update class is MINOR
10/02/21 17:21:13 dataLog: service started.
10/02/21 17:21:15 dataLog: Last log entry 10/02/21 17:15:10
10/02/21 17:21:18 Updater: Auto-update is current for class MINOR.
10/02/21 17:21:18 historyLog: service started.
10/02/21 17:21:18 historyLog: Last log entry 10/02/21 17:15:00

It sounds like poor WiFi. The RSSI is below -70, which is not great, but works well for some. It could be the AP, or another high bandwidth device on the same frequency. It doesn’t have to be a WiFi device. Try setting your router to use a different channel.

Thanks again, that was the problem indeed.
I setup another Wifi AP close to iotawatt, and now performance is excellent !


1 Like