Problem connecting to IotaWatt thru a network repeater

My IotaWatt is installed, configured and works. It is installed at the extreme edge of my home network (“Legoland”) therefore it only works intermittently. RSSI is between -85 and -90.

I installed a GL-iNet (Mango) router between the home network router and the IotaWatt. When the IotaWatt is connected to the Mango network it can be accessed by my phone or laptop if they are also connected to the Mango network. If the phone or laptop are connected to the home network (Legoland) they can not connect to the IotaWatt. I tried using the Mango network name in the iotawatt address (HTTP://GL_MT300M-V2-36e/IOTAWATT.LOCAL), but I get a “This site can’t be reached” error.
Below are configurations from the IotaWatt status display when connected to Legoland and to the GL-iNet networks.

image

image

I can provide data logs if that would help.

What additional configuration do I need to do to be able to see the IotaWatt on my home network?

Thanks for any ideas.

It doesn’t look like that’s a network repeater. It has a whole different subnet scheme (192.168 vs 10.0). I have a cheap TPlink remote access point in an outbuilding wired to my home router. The access point does not have a DHCP server. Devices that connect to it get their IP from the home router, so they are essentially on the same LAN, so I can access from the home LAN.

The .local protocol relies on the ability to broadcast to all devices on the LAN to locate the IoTaWatt (or a printer etc.).

There are a lot of details that are device specific, and you’ll need to work that out, but that’s the jist of it.

I kind of suspected that but my knowledge of networks is limited. I may have it configured incorrectly.

I got the Mango based on comments by others in this forum.

1 Like

@larry.h, if you didn’t change the “network mode” on the Mango (“More Settings -> Network Mode”), then it is in the default “router mode,” so it is likely behaving similar to your home router/firewall/access-point device: anything on its network is “secure” and anything elsewhere is “insecure.” (I use these terms loosely.) Think of the Mango as your home router/firewall/AP: anything in your home network is safe, but anything outside your home, trying to get in, is blocked. So, the Mango is “protecting” your home network devices from getting to the devices the Mango has let onto its network.

Think of it like a nested set of protected networks: your home network is protecting your home devices on the Legoland network from the nasties on the Internet, and now additionally the Mango is protecting the IoTaWatt from the devices on your Legoland network.

I changed the network mode on my Mango to “Access Point” so that it acts only an a wireless access point (WAP) on my network, i.e., it does no routing or firewalling. (I have mine hard-wired with a CAT6 cable.) In this mode the Mango becomes just another client on your home network (you can have it pick up a dynamic or static IP address from your home router’s DHCP server), and then wireless devices that connect to the Mango SSID (i.e., the IotaWatt) will also get their IP addresses from your home router’s DHCP server. At that point, everything should be in your same home network and you should be able to access the IotaWatt from your phone or laptop in your home network “Legoland.”

Cross reference other thread here: Remote mounting IoTaWatt from electric panel

Network mode on GL-iNET devices: https://docs.gl-inet.com/en/3/setup/mini_router/more_settings/#network-mode

2 Likes

I had some similar problems connecting to my unit which connects to a wifi access point (on the same network) in my shed. Sometime it would connect, sometimes not. I solved the problem by just assigning the unit a fixed IP and using that to connect. Never had a problem since.

@larry.h - just repeating what has been said here by @zipzap

  1. Get rid of the default firmware and upgrade with OpenWRT - it is straight from the main menu and very easy to do

  2. Put the unit into Access Point mode - this basically means it copies everything from the Wireless network to the Cable that you plug into it (plug the cable into the LAN port not the WAN port)

  3. On your DHCP server on the network (probably your main Wireless router - have a look for the Mango router showing up and then assign it a static IP address - this is done differently in every brand of router)

  4. Plug the ethernet cable from the Router/Switch into the LAN port on the Mango.

  5. You should be able to use a Web browser to connect to the management interface of the Mango - with the IP address that you set in point 3 above

  6. Set the Wireless network to be the same name and password as your main wireless

  7. Reboot the IOTAWatt and watch the main router - you should see the IOTAWATT come up and request an IP Address

Should all be good then

Craig

@ZipZap & @craigcurtin thanks for your response and guidance. Im getting closer but not there yet.

Not sure what “Get rid of the default firmware and upgrade with OpenWRT” means. I upgraded the software in the mango via the mango website. It mentioned openWRT.

I don’t have Cat5 cable in the garage so I’m trying to use the mango as a Wi-Fi repeater. I have reasonable home network signal strength where the mango is located. It should be able to repeat the signal to the IotaWatt about 20 feet away.

I don’t see anywhere in the GL iNet menu how to setup the wireless as an “Access Point”. Is Access Point only available when the GL iNet is connected via Cat 5?

I did connect the mango to my home network (legoland) and set the mango wireless network name and password the same as the home network. Rebooted Iotawatt and it connected to Legoland. When I am in the garage and my phone is connected to Legoland, I can see IotaWatt. The IotaWatt wifi status shows a 192.168 IP address not a 10.0.0. When I am in my office and phone is connected to Legoland, I can not see IotaWatt.
image

I did a network scan from my desktop computer using NetSpot. The desktop is connected to the home router via Cat 5 cable. Both Legolands show up.
image

I know I need to set the IotaWatt and Mango to static IP address but I’ve never done that. I have an Xfinity gigabit modem & router. The vendor appears to be Technicolor. The DHCP beginning address is 10.0.0.2 and the ending address is 10.0.0.253. So I guess I need to change the beginning address to something like 51. Then I could set the Mango IP address to say 30 and the IotaWatt IP address to say 40. Does sound right.

I still don’t think the Mango is configured correctly. It looks like it is still acting like its own router and assigning its own IP addresses.

Again any additional comments are appreciated.

Thanks again
Larry

@larry.h, I didn’t realize you weren’t hard-wiring with CAT 5, so I think “access mode” is incorrect, and I apologize for suggesting that. I think you want “extender” mode in the Mango (“Extend the Wi-Fi coverage of an existing wireless network.”). See here for a screenshot of where it is in the Mango UI:

https://docs.gl-inet.com/en/3/setup/mini_router/more_settings/#network-mode

I think what you have now are two wireless networks that just so happen to have the same name but are two entirely different networks. Again, apologies for not understanding your network.

I personally have not tried “extender” mode, so beyond choosing it and following the UI, I can offer no further help. I have found the GL-iNET UI to be pretty good at walking you through things.

I think you are this close, though!

Giving a static IP to the Mango never hurts, and offers a little more stability, but I’m hoping you can get the “extender” mode working first before going the extra step with a fixed IP address.

With respect to @craigcurtin’s suggestion of installing OpenWRT, I think that’s optional at this point. The GL-iNET under the hood is running OpenWRT already, but very likely an older version that will not be updated as frequently as the OpenWRT code is updated and released. I do plan to do that with mine eventually but the Mango should work fine for this purpose as-is, i.e., with the GL-iNET UI on top of the OpenWRT that it shipped with.

1 Like

@zipzap, Looks like that information was the piece I was missing. I’ve read the GL iNet manual at least twice but have missed that section. I also now see where Access Point is set.

I reconfigured the Mango per the Network Mode section of the GL iNet manual. Disconnected IotaWatt from existing network and powered it off. Powered up Mango, let it connect to Legoland. Powered up IotaWatt, waited for RED Green Green, then connected to Legoland again. Per my understanding, IotaWatt should connect to the home network (Legoland) via the Mango since it is the stronger signal. NetSpot shows the Mango power level (green) about -25 and home network (Legoland) power level (red) about -61. These measurements were taken about 10 feet from the Mango and about 8 ft from IotaWatt.
image

Called up IotaWatt.local and response seemed very good for a couple of minutes then it froze! Was able to reconnect and Iotawatt Power Monitor, WiFi section still shows RSSI of -85 to -89. The IP address was again 10.0.0.42. This tell me that IotaWatt is still connecting directly to the home network and not going thru the Mango.
image

With the Mango powered off I was still able to connect to the IotaWatt.

I think I’ve got some old CAT 5 cable that might reach the garage and I may try setting up a temporary wired Access Point.

Thanks for your help. I am open to more ideas.
larry

My remote AP is now wired, but when I was using a wireless bridge, I used a different SSID. It still played back to the main router and I could access devices on the AP. So if you have the option of setting the SSID for the bridge, try a different ID.

When the IoTaWatt connects to Legoland, disconnect using the WiFi setup tab, restart and connect to the new AP.

@overeasy, thanks for the comment. I tried to use a different SSID but the configuration application uses a dropdown list of available networks. So trying a new name is not possible.

I’ve posted my issue in the GL iNet forum. Maybe some of those guys can help.

thanks again.

@larry.h, so sorry you are having so much trouble with this little thing; I now consider myself lucky that the setup was straightforward for me!

Good idea heading over to the GL.iNET forum. If alzhao responds, I believe he works for the company; he answers a lot of questions there.

I just checked my own notes, and my Mango came with firmware V3.102 and I immediately upgraded to V3.105 before I did anything. V3.105 is still their default release:

https://docs.gl-inet.com/en/3/release_notes/

But, if your Mango is going to be solely for your IoTaWatt (like mine is) you might try to upgrade to their “pre-release” V3.201. Unfortunately, I cannot find release notes for anything beyond the “default” release, in order to see if any of the extender features/bugs have changed.

I just now bought another Mango. I wanted to try the OpenWRT firmware as @craigcurtin suggested, but since my Mango is “in production” on my home network, I don’t want to risk bricking it. (I’m risk-averse!) If it arrives before you get this resolved, I’ll try “extender” mode as well, before laying down non-GL.iNet / straight-up OpenWRT firmware on it.

@larry.h I was looking more closely at your screenshots, and something looks inconsistent. The Mango you said is green (on channel 11) at -25. Your (original) Legoland: “red” (on channel 11) at -61 (looks pink to me). The IoTaWatt screenshot, however, shows channel 11 at -86, which would correspond to the dark yellow? dashed channel 11 in the channel screenshot.

Maybe these were taken at different times, at different distances from the APs, which could explain it. Or maybe something else is going on.

Not sure if changing the channel on the Mango to something completely distinct from your Legoland network might be appropriate (like channel 1 or 6), at least for troubleshooting. Or, it might be because it is in extender mode and acting as a repeater/bridge that is requires exactly the same channel and this is not an option. (It is in router mode, where you can manually set the channel number.)

Anyway, something to chew on or try, while we wait for folks in the GL.iNET forum to respond. :slight_smile:

Curious, for the few minutes the IoTaWatt connected to the stronger Mango Legoland, did you happen to notice the IP address? Same network as your home Legoland…or something different?

Lastly, @overeasy said something that you might try as well: forcibly disconnect the IoTaWatt from the wifi and set it up again. Maybe it will find the stronger Mango Legoland and stick to it, despite the SSIDs being the same.

@zipzap, thanks for your additional comments.

I did upgrade the Mango firmware based on recommendation from @craigcurtin . Current version 3.201. This was the only option on the GL iNet website.

Re Power levels. The Red (pink) and Blue are correct. It is difficult to compare numbers from 2 different “uncertified” measuring instruments. The IotaWatt antenna, radio, amplifier, algorithm, etc will affect its interpretation of RSSI. Similar comment on the readings from the Laptop. In addition, the IotaWatt is about 8 feet further away from the Legoland router and the Mango expander than the laptop when it made the measurements.

When I had the Mango in router mode and the IotaWatt connected to Mango network, IotaWatt reported RSSI of -58. (see picture in original post) I would expect similar RSSI when Mango is in Expander mode.

I’ve looked at changing the channel. My modem/router is from xFinity. The channel is “automatic” and can not be user set. I may try calling xFinity in the future.

I have been using the recommendation by @overeasy. My procedure for trying a new connection is: Disconnect from the existing network via the RED Wi-Fi disconnect button on the IotaWatt Power monitor page, get red light, Power down IotaWatt, make changes in Mango, Power up IotaWatt, wait for Red Green Green blinking light, establish new network connection.

Thanks again for your comments. No response yet from the GL iNet forum.

Sorry Guys - been away for a couple of days

Basically what you want to achieve is to have the router in Wifi repeater/extender mode.

This mode effectively takes the wireless signal from the main router and then repeats this out - thus pushing the signal further down the line. The downside of this mode is that you lose 1/2 your network bandwidth to the downstream nodes - in this case as the amount of data that IOTAWATT sends is miniscule this is not an issue.

Follow this setup guide

Craig

@craigcurtin, thanks for the reply and additional comments. I think Im close but cant find that final step. So far there has been no response from the GL iNet forum.

It is my understanding that in expander mode I would configure the SSID and password in the expander network the same as the SSID and password of the home network. Is this correct? Is this the same as when configuring the Mango as an “Access Point”?

BTW, I ran a temporary Cat 5 cable and configured the mango as a Access Point and it did not work either. I ran out of daylight to trouble shoot that. Maybe later in the week.

I am seriously considering going back to plan A, extend the CT cables. I’ve moved the IotaWatt from against the wall in a corner to hanging from the ceiling about 4 ft closer to the home router. The IotaWatt is now reporting RSSI in the -81 / -83 range. Sometimes -79 / -80. This appears to have improved my connectivity since I can now start verifying my configuration and the system does not freeze or drop out nearly as much. With 25Ft cable extensions, I can move the IotaWatt about 20 Ft closer. I would run the extensions in EMT since the route is parallel to power cables.

My Comcast / xFinity modem/ router channel is set automatically. It has always been Chan 11. Last night I noticed it was Chan 6. I could still access IotaWatt.local. I guess all these smart boxes know how to deal with that. Today it is back to Chan 11.

Thanks again

Larry,

Yes in an extender/Bridge mode you are duplicating the real network details - so same SSID and password

No when you configure as an access point - the Mango assumes that you are going to plug a cable into the LAN or WAN port and tha any wireless traffic will want to go out one of those ports.

In Access point mode it will want to act like a DHCP server and create havoc on your network.

I can guarantee you if you can put a cable out there and then connect into the LAN port of the Mango it will work when in access point mode - i have 4 of them here in my house and thats exactly what they do.

You will still get drop outs of the IOTAWATT with those sort of RSSI levels.

Craig

@craigcurtin
Let me try the cable & access point again Monday. Getting a permanent cable out there is still a problem but that appears to be the long term solution.
thanks
larry

I tested the Cable and Mango Access Point connection today and no success.

I connected the cable from my router to the WAN port on the Mango. Do I leave it there or move it to the LAN port?

Does this configuration look correct? Is DHCP correct?
image

In “MORE SETTINGS > Network Mode”, I selected Access Point

When I am configuring IotaWatt for a network connection, I see the GL MT300 network and the Legoland network.
image

I can connect IotaWatt to Legoland and it goes to the home network, Legoland. I can not get IotaWatt to connect to the GL MT300 network. IotaWatt stays in red green green mode.

This Mango may go in the electronic recycle bin this weekend.

SUCCESS !

Actually I got the wireless to work. No cable needed. This has always been my goal. RSSI -55, IP 10.0.0.42. Life is good.

I’m embarrassed to admit that I was using the wrong password while trying to connect to the Mango network.

A big thanks to @overeasy, @ZipZap and @craigcurtin for all your help and guidance.

2 Likes