Problem with the CT's

Hey everybody,

I’m actually trying to configure a IotaWatt and all was good since I tried to plug the CT’s to see if I could see somme values : the problem is that they are displaying 0 watt for all the inputs I tried. I am using the SCT013-050 from YHDC and I have already tried them on the same electrical cable with an emonpi (they are plugged on the allimentation cable of the emonpi). On the pi they are measuring continuously between 10 and 30 W, and if I go to graph + the vallues are too much low (max 400mW) and I do not observe any difference when they are plugged in or not. I’m joining you the screenshots of the IotaWatt interface so you can see cearly the problem.

I would like to thank you already for the help you could give me.

SCT013-050 are voltage type CTs and are not supported directly by IoTaWatt. The SCT013-000 (100A/50mA) supported. That’s what you have configured but not what you are using.

I am sorry it was an error i made. I am well using the right CT’s (here is a pick of one of those).

Can you post a picture of the CTs as they are installed please?

Of course. As I said they are all plugged on the emonpi’s alimentation.

OK, I didn’t understand what you meant by alimentation.

There are three problems here:

  1. That cable to the EmonPI is providing DC power. IoTaWatt only measures AC power.

  2. The CT is clamped aroung both of the current carrying conductors in the cable. The current goes in opposite directions so they cancel each other out. You always need to put the CT on only one of the two wires of a circuit.

  3. The EmonPi uses maybe 5 - 10 Watts of power, which is a very small quantity to expect highly accurate readings.

Your VT is measuring ~230V. The circuits that you measure with the IoTaWatt must be 230V AC circuits and you must place the CT on only one conductor of the circuit.


Obviously I need to revise my eletricity lessons…

Thank you so much for your help !