PV Output uploader Failing

I’ve been using my IoTaWatt for a while, mainly through Home Assistant Integration, and its been working great, but been having issues also trying to get the data into PVOutput.

It keeps trying to upload, then has an issue, crashes and it tries to start again, the error in the log is below. It worked for a few days of data, then stopped working with this error, so im not sure if I have some bad data somehow thats getting rejected?

Unrecognized HTTP completion, upload Bad request 400: Missing parameter [data

Can you post the message log and your PVoutput setup please?

iotawatt-messagelog.txt (9.7 KB)

The 3 inputs to pvoutput are all straight inputs, not using any outputs or integrators

And the message log?

I attached it in the previous response, it’s linked above the screenshot

Sorry, missed that.

OK, I don’t know why you are getting "Missing parameter [data…
It appears to be happening when restarting after hitting the rate limit. But I think it’s moot right now since you are not a donator.

You are trying to upload data from Oct 1. - about 60 days. At 5-minute intervals that’s 17,280 status updates.

In freeloader mode, you can upload history up to 14 days in the past. You can do 60 uploads per hour and each upload can contain a maximum of 30 status records (5-minute frames). So that’s 30 x 60 = 1,800 status updates per hour or 6.25 days of data per hour.

With Donator mode you can upload history up to 90 days. The Rate-Limit is 300 uploads per hour and each upload can contain a maximum of 100 status records. That’s 300 x 100 = 30,000 status records per hour or 104 days of data per hour.

So, you have a couple of options:

  1. Change the upload history to November 19 or greater to stay within the freeloader limitations.

  2. Become a donator and upload all of the data from Oct 1 without hitting the rate-limit.

Understand that I don’t know why it failed after restart. It could be a problem with your datalog, or it could be related to exceeding the limitations of freeloader mode. I can look into that but first I would recommend that you try option 1 above and see if it succeeds. It should stop twice for rate limit but eventually complete after 2+ hours.

If you then want to make a donation (15 AUD), you can do so and reset upload history to Oct 1. That should complete in an hour, but if there is a data problem it will cause the error again.

When you have completed the history upload, you must clear the upload history from parameter from your PVoutput as it will try to upload every time you restart.

iotamsgs.txt (9.7 KB)

I set the upload date to the 25th, and it still seams to have the same issue.

I’ve read a bunch of similar issues, and there seams to be small usage overnight from the inverter, which may be causing the issue? If it is I’m not sure how to clean up the data

Generation = Solar max 0

You can give that a try, but I don’t think that’s the problem. I’m looking into it.

EDIT: I’ve recreated the problem. It has to do with restarting after hitting the rate limit. I will fix it but won’t make it out into a release for probably a month or so. In the meantime there are two ways to work around it:

  1. Set the upload from date to no more than 5 days ago so that all of the data can be uploaded without hitting the rate limit.

  2. Become a donator and set the upload from date to no more than 90 days ago.

Just wondering if this is going to be in the 02_08_02 release?

It is in the 02_08_02 release.