Reading not power, but directly current values (amps)

Hello there,
I am trying to do some current measurements on three phases without having to take three different voltage sources.

I would like therefore to use the IotaWatt to do current only reading, i.e. with no voltage input at input 0, only CT’s connected.

Do any of you know how this can be done?
IoTaWatt provides by default a power reading (W), so there must be a raw data of current (A) somewhere in the code… any easy way to show this to an output?

Thanks a million,


Yes and No. Yes you can do it without three different voltage references, no you can’t do it without any voltage reference. The way IoTaWatt gets everything done while still maintaining a high sample rate is to synchronize on the phase of the voltage reference. So you’re right, it doesn’t need to know the amplitude of the voltage reference, but it does need the basic tick-tock that it provides to define the duration of each cycle.

With three phase, measuring only current, it doesn’t even matter that the voltage may be out of phase with the current sample. As long as the sampling begins and ends at the same point in the current cycle, the rms amps will be correct.

Absolutely. You can output amps to the status screen by defining an output with units=amps. In fact you can define an output that is the sum or difference of any number of inputs. You can also output amps to Emoncms or influxDB. Other units available are of course Watts, Volts, VA, PF, and Hz. You can also export Wh and kWh.

Hi, maybe stupid question, but how can I send PF and HZ to outputs?

Select those units when defining the output:


When asking for frequency (Hz), be sure you are specifying a voltage (VT) type input. When asking for power factor (PF), be sure you are specifying a power (CT) type input.


This works exactly the same when specifying outputs to Emoncms or influxDB.

I tried to edit the Outputs, but i noticed a big difference from your screenshot and my… on my case I do not have a dropdown to select the Units… is is only a text field.
I tried just by inserting the text, but on the output I have the value of the Voltage ;-(

In case I have Firmware version: 02_02_30.

Oh, sorry, you’re right, that’s not in the 02_02 versions which are still current for MINOR and MAJOR versions. The units was introduced in 02_03_03 and is still in ALPHA. The current ALPHA is maturing and will be available in BETA, probably over the next few weeks.