Red green Green light but no SSID


I’ve got a brand new IotaWatt and this is the first time I’m configuring it.
It started off with a rough start. I plugged the IotaWatt in and it only had a red dull light. So after turning it off-and-on again it started to produce the R-G-G light. I found the SSID, connected to it, and connected the IotaWatt to my home network. I disconnected changed my wifi from my pc back to my home network, but the IotaWatt keeps displaying the R-G-G light, but now I can’t find the SSID anymore to connect to it. I tried turning it -off-and-on again multiple times, but nothing… help.

Kind regards

Hi Bram,

Not sure what causes your problem. Anyway, if the IotaWatt can not find the WiFi network it will go back to Access Point (AP) mode. So by temporarily disabling your WiFi you can try to configure it again.

You can also have a look at this:

Good luck,

Would you mind telling me what country you are in and when and where you purchased the IoTaWatt?

Hi Jascha
I switched off the wifi, but I still can’t find the IotaWatt.

Hi Overeasy

I’m in Belgium. I bought the IotaWatt from

OK, Thanks for that.

So when you power cycle the device, it comes up with RED-GREEN-GREEN. Try it and wait five minutes. Does the LED sequence change to something else?

So when I try it on the first 4 second it turns green. Then it starts the sequence R-G-G. Even when I wait for half an hour it still keeps running the cycle R-G-G, but without SSID

You are probably right, but there can be a subtle difference, and there was not time between when I asked the question and when you responded for you to wait that long. So could you try it again please.

So I switched off my wifi, made sure the iotawat was switched on (only by the 5V dc cable) and watched the news (which takes about half an hour). After that I still couldn’t find it and the sequence stayed the same. this happened between my first post and the reply, but it never hurts to try again :). So now it has been connected for 10 minutes and didn’t change.

OK, that was important. If it had changed to RED-RED-GREEN, that would be much easier to solve.

So this now falls into the category of “This should not have happened”. So I have to consider the possibilities. At this point, it doesn’t really matter if the SSID is broadcast or not. It should not stay RED-GREEN-GREEN for more than three minutes. So given that is indeed the case, the problem might lie in components outside of my purview. Without a doubt this is rare, so it probably has something to do with local conditions. There are so many combinations it’s impossible to say.

Now there are several ways to proceed, depending on how much you can and want to do.

If you know how to access the client tables in your router, see if the IoTaWatt is connected. It should have hostname iotawatt. I doubt this is the case, but would be interesting if so.

If you want to open the device up, remove the SD card, and mount it on your computer, the file /iotawatt/iotamsgs.txt may contain clues. You could post that and I’ll see what I can see.

You might try turning off the device that you initially used to connect to the AP and see if the AP appears on a scan with another device, while your wifi is switched off.

Another option is to could contact OEM and try to return it for either reflashing and testing, or replacement.

Hi, I appreciate the help!

So I tried to find the SSID also with my phone, but I couldn’t find it. I have the Iotamsgs.txt file and it’s here: IOTAMSGS.TXT (8.6 KB)

Since it’s new I don’t really know how it should work or whatever, so I’m not really eager to flash it or so. So I’ll contact my supplier and ask if they have any tips to resolve it or to send it back to them so they can test it.

I looked at the log file. The unit has never connected to your WiFi. There should be an SSID broadcast. I think it’s odd that you did receive it once and now it’s gone. So the unit appears to be stuck in the WiFi configuration code, which is a black box to me.

I definitely think it should be reflashed and tested at this point.

Alright thanks. I’ll ship it back and let you know when I got some more news


So I got a reply from the guys from OpenEnergyMonitor and they encountered the same problem as I described. They’re sending me a new, tested , unit to me. Great service.
Thank you Overeasy for the help and the advice.