Red Green Green lights and unable to progress to Device Configuration

Hi Bob I have been trawling the forum subjects as requested (my email 16 July re order #1283) and continue to be unable to get passed the scan, connection, password entered and screen saying…

After entering the password successfully I am getting red-green-green flashing light and it fails to connect or allow me to do the configuration step. I have retried many times and get stuck at the same spot. I have switched off my wifi to force the new connection to the device and get to the same point every-time. I have used IOS, Safari and Chrome browsers on my MacBook Pro and end up with red green green which indicates its not reaching the network.

I have tried two different routers and unplugging everything, rebooting and no joy, same result.

I have rung a buddy who has one of your devices and we walked through the steps, he can get through but I cannot and he suspects the memory card may need re flashing? I have not tried removing and checking the logs… should I be doing that? Hope you can help/ . Cheers JB.

Hi John,

So it’s been over a month since that email. At the time, the reported problem was different. You reported that after entering the WiFi credentials, the LED went to dull green, which indicates a connection was established. Moreover, to get dull green, the IoTaWatt would have sucessfully retrieved the time from the internet using that connection.

This situation is different. RGG indicates that the connection is not established. You’re not telling me what has rtranspired in the month and a half since that first email, or what else has changed. So there is a universe of possibilities as to what might be going on. I don’t put the need for reflashing high on that list.

So rather than try to do twenty questions to understand how you got from there to here, i think it would be helpful if you could post a copy of the log. Given that you can’t access the IoTaWatt, you would need to open it up and remove the SDcard (be sure it is powered down when removing or replacing the SDcard!). The file is in /iotawatt/iotamsgs.txt. Please upload that file and I’ll have a look.

Hi again,

Yes it has been a month but to be honest I have tried to connect a few times and not had time to diagnose or follow up again.

Yes the dull green was seen once, I was able to add one CT and test before the rest of the CT’s could be installed. Since then I have had all CT’s installed and had to replace my wifi router and this has meant a retry from scratch and here we are with the red green green sequence.

I have removed the SD card and it has a read error. I have noticed the card has a crack in it (its not flat) I am guessing it is faulty as I have checked my reader with another SD card it works fine. I am wondering if this may be part of the problem?

I only have a 2GB SD card, can we reload the files required on it and retry to connect and diagnose? If so please advise what I need to put on the card? Your card is 8GB, does it need to be that big?

No idea how the card may have been cracked or faulty? Hope we can recover. Thanks.

So then you were able to access the IoTaWatt and configure the one CT. Then you changed routers and since have been unable to connect? Those are important chapters in this story.

There is no way you could get RGG with a damaged SDcard. There are two possibilities. Either the code was actually GRR (SD card damaged), or the card was damaged just now when it was removed.

Either way, the problem now at hand is a damaged SDcard. You will need at least a 4GB card, but an 8 is recommended. These days, it’s hard to buy anything smaller than an 8Gb.

When you get a new card, install all of the files found here: https://github.com/boblemaire/IoTaWatt/tree/0-2_04_02/SD

Reinsert and restart. Then we’ll deal with the next problem if there is one.

Hi again, The code was definitely RGG so it may have been damaged on removal, I cant exclude that as it was a bit stiff. I will get another card and copy and see how we go.

I think I can exclude the router as the difficulty I am getting happened with the original router after I had the CT’s connected. So many tries I am nearly over it… Let’s see how it goes and will advise.

Hi. I now have a 16gb SD card and am feeling a bit silly but I cannot see how to down-load the folders and files in the list. I have downloaded the zip file and have these folders42 . They don’t quite match up so reluctant to copy them as is. Please confirm if what I have is what I need or there is a simple way to copy the files. Is it the SD card folder. Sorry for being a bit thick…

Yes, you want the contents of the SD folder in the root directory of your SDcard.

Hi again.

Same light sequence and lack of progress.

Files from SD card. Hope it sheds some light.

IOTAMSGS.TXT (2.0 KB)

The log indicates that when you first powered up with the new card, the IoTaWatt successfully started and connected to your WiFi network. It was able to connect to the IoTaWatt.com service via the internet to verify that the firmware version is current.

The led would have been dull green at this point.

Several seconds later the power was cycled off/on. The device restarted, but now the WiFi was not available and so the LED would go RGG.

This is where it gets hazy. The next log entry is time-stamped about 4 hours later. Something happened, but no connection was made. Then an hour later, the IoTaWatt logged that it was restarting because there was no WiFi connection, yet there do not appear to be any log entries to indicate the restart.

By your post, you are saying that at this point, the LED was RGG when you removed the SDcard to post the file. I’m at a loss to understand how that could be the case.

Hi again. Finally I have been able to connect, configure and use the device.

The only thing I can think I did differently was that after getting the credentials message having entered wifi password I just left it for 10 minutes and it seems to have allowed it to do its thing.

Thanks for your patience.

PS when adjusting the calibration ratio factor am I trying to get the ref as close as I can to 240v? System says when running having done that is showing 237v. Is this ok or am I missing something?

Would need to see the log to comment on that. The only potential time consuming activities are obtaining the time and updating firmware. You had already set the time, and I believe the firmware was current.

Whatever the cause, I’m glad it sorted out.

I think what you are saying is that you adjust the calibration until the voltage shows 240, then when you look at voltage in the status display, it’s 237. Assuming that, are you sure you saved the new calibration value or that the voltage has not dropped 3V since you calibrated?

What are you using for a reference when “calibrating”? If you are just setting it to the nominal voltage of 240V in Australia, without using a decent voltmeter, it is likely less accurate than using the default calibration if you have one of the VTs that are in the tables. I have samples of those and have calibrated. Admittedly I only have one of each, but when I test three of the VTs that I sell, they cluster within 0.5%.

If your status display voltage is not within 0.5% of a decent voltmeter, you should calibrate again.