Red led status after wifi setup

Hi, I’m a new user trying to setup the device for the first time. My problem is the following:

There’s an exclamation mark (!) in my PSK. So let’s say my wifi password is “password!”. Iotawatt was not able to connect to the network with that and after a few tries I noticed the web GUI configures the device via HTTP POST (“p=password%20” in the address bar). I modified the URL to “p=password!” but now the status led is red all the time and Iotawatt is not broadcasting its setup SSID anymore. I’ve tried to restart the device several times and remove the battery and SD card with no luck - the led turns from green to red right after powering up the device.

Is re-flashing the only option or is there something else I could still try?

I’ve never tried to use special characters in the PSK on setup. That code is part of a WiFi Manager package that I use and not really practical to try to change it. Your browser is probably changing the exclamation point to URL safe code. %20 is a space, it’s probably %21. In any event, its not going to work.

Have you tried kicking it? Why does everyone try these desperate measures with no indication that it has anything to do with the problem. In the end, what I get is a potential compound problem. At this point I don’t know if you are connected but the clock is just not running (battery removal) or if there is some other problem with the SDcard.

If you want to send it in I’ll restore it to factory state. When you get it back, you will need to connect it to WiFi that does not have special characters in the PSK.

Send it to:

IoTaWatt, Inc.
92 Sewall Rd.
Wolfeboro, NH 03894

Please enclose a copy of this email and specify your original order number.

How did you know? Kicking it is exactly what I was about to try next. :wink: Joking aside and to be honest, as a customer who spent over 200 USD alone for postage and taxes to get your product it feels weird and a bit bad to receive a response like this from you. Don’t get me wrong, I appreciate your help but maybe you understand my point.

Anyway, I kept restarting the device because it helped first. I mean after configuring my PSK for the first time the led was red. After a couple of restarts the led status changed and the device broadcasted its SSID again. I was sure I fat-fingered my password on my first try but after re-typing it carefully it was still the same. On my third try (again after a few restarts) I noticed the URL thing and tried to modify it and since then the led has been constant red.

I tried to remove the battery as I found from this forum that it had helped for somebody. I tried to remove the SD card just to make sure the contact wasn’t bad. Hell yes it was desperate but I’d say it was still worth trying.

However, it works now (with a special character in the PSK). I checked the logs from the SD card with a help of an Android tablet and noticed the device had been able to connect a couple of times. For some reason I didn’t see an ARP entry on my firewall yesterday, though, and that along with the fact the documentation strongly suggests that red light means a network problem made me think the problem indeed was on the network connection. Anyways, I gave it some time to start one more time, was able to see the device on my network and after plugging in the 9 VAC the led magically turned green.

Thanks to you I’m now able to see the energy consumption just like I have always wanted:

From my perspective, I would expect you to protect that investment by asking for help before taking it apart.

My definition of desperate differs from yours. You had not yet attempted to get any help either through the forum or by

I’ve got a pretty good track record of working through install problems. Not so much working through the results of compound issues when folks have taken the thing apart. Trying to do that in the forum across time zones is extremely difficult and frustrating. So, my policy now is that if you take it apart on your own, I will fix it if you send it back.

I’m glad you were ultimately successful. By your description it did not have anything to do with the battery or SDcard and certainly didn’t need re-flashing.

I totally understand your point of view. Dealing with customers is frustrating. Doing it alone(?) is even more frustrating.

However, there’s my point of view as well. If we for a second put aside the fact that I should’ve known better if the device is even connected to my network or not, there are two things that would have helped to solve the issue easier:

  1. Physical factory reset button on the unit. That would help to isolate many problems. It’d also resist customers’ temptation to take the thing apart. Maybe something to think about for the next version?

  2. Clearer documentation regarding the constant red light status. One of my (obviously many) mistakes was to believe that red led means no network or internet. In my case it meant “please plug in the 9V transformer ”.

The setup is pretty clear with regard to the 9VAC being a critical component:

Not following the basic setup, or checking it when there is a problem, is a recent trend. Adding more language to the docs just makes it more probable that users won’t read it. While the red-glow is not indicative of the lack of AC, it is part of the compound problem created by removing the battery. The latest release, now in BETA, makes the unit more robust when users don’t connect the AC reference.

Well, it’s obvious the AC reference needs to be connected to make the device work. For initial setup it’s practical to test the connectivity first before moving the device to its final location, though, and that’s what I was doing. It’s very confusing to see a red light at that point. And just to correct one more misunderstanding, the red-glow was there before removing the battery, I did not cause it by taking the device apart.

Adding a few more words about the red light behavior to the documentation doesn’t make the troubleshooting section of the documentation worse, it makes it better. But obviously you don’t want to understand my point and that’s fine. You do what you think is best for you and your product.