RESOLVED - InfluxDB stopped updating

Hi all,

I purchased and installed an IoTaWatt last July and it has been great. I have had zero issues with the device pushing data into my InfluxDB server until March 15th. I should note that nothing has changed with my network or InfluxDB, and all other devices (IoT, servers, desktops, etc.) are able to log successfully.

The IoTaWatt was running 02_05_02 on the MINOR update channel. I changed to a new database and reset passwords. Still nothing. I changed to BETA channel and it updated to 02_05_05. Same thing, no go.

You’ll note that the InfluxDB server is on one subnet and the IoTaWatt is on another - along with all the other IoT that is reporting fine.

Would it be possible to turn on debug logging on the IoTaWatt?

This is what the log is currently telling me:

SD initialized.
3/21/20 23:36:37z Real Time Clock is running. Unix time 1584833797 
3/21/20 23:36:37z Reset reason: Software/System restart
3/21/20 23:36:37z Trace:  1:5[7], 7:0, 7:5, 1:6, 1:3, 1:4, 1:5[7], 7:0, 7:5, 1:6, 1:3, 1:4, 1:5[7], 7:0, 7:5, 1:6, 1:1, 1:2[1], 9:0[1], 9:0, 9:1, 8:4, 8:6, 8:8, 8:9, 9:3, 9:5, 9:9, 1:2, 1:3, 10:2, 10:3
3/21/20 23:36:37z ESP8266 ChipID: 2518017
3/21/20 23:36:37z IoTaWatt 5.0, Firmware version 02_05_05
3/21/20 23:36:37z SPIFFS mounted.
3/21/20 16:36:37 Local time zone: -8:00
3/21/20 16:36:37 Using Daylight Saving Time (BST) when in effect.
3/21/20 16:36:37 device name: IotaWatt
3/21/20 16:36:37 HTTP server started
3/21/20 16:36:37 timeSync: service started.
3/21/20 16:36:37 statService: started.
3/21/20 16:36:38 dataLog: service started.
3/21/20 16:36:39 dataLog: Last log entry 03/21/20 16:36:35
3/21/20 16:36:39 historyLog: service started.
3/21/20 16:36:40 historyLog: Last log entry 03/21/20 16:36:00
3/21/20 16:36:42 influxDB: started, url=, db=iotawatt3, interval=5
3/21/20 16:36:42 Updater: service started. Auto-update class is BETA
3/21/20 16:36:42 WiFi connected. SSID=REDATED, IP=, channel=1, RSSI -60db
3/21/20 16:36:44 Updater: Auto-update is current for class BETA.
3/21/20 16:40:22 influxDB: last entry query failed: -4, retrying.

Is there a log on InfluxDB on the destination that might give any information? (I hesitated to post this as I run it in Home Assistant, and I looked before posting and cannot find any InfluxDB log, but I’m sure there is some way to do so).


The return code from the query failure means connection failed. There is some issue with IoTaWatt connecting to the influxDB server. If you know how to use wireshark you might get some additional information looking at the connection attempt. It’s not obvious looking at the IoTaWatt log that the IoTaWatt and the influxDB server are on different subnets as you state because the subnet masks are not visible, but if that is the case, notwithstanding that other devices may apparently be bridging the divide or nothing has changed, you might investigate that or try putting the IoTaWatt on the same subnet as the server.

Can you ping the IoTaWatt from the server running InfluxDB?

Thank you SO much for suggesting trying to ping. I had spent more time than I want to admit looking at this and I never tried to ping. It turned out I couldn’t ping much of anything from in the docker host, and it was returning a weird IP which pointed to an issue with ARP - odd that the only service that was having issues was IoTaWatt, I’m sure there is a reason there if I was more educated on the topic.

I knew I had a ton of docker networks from prior configs but until the 15th they didn’t cause any issues. I removed all of my docker containers and networks, and recreated all of the containers (docker-compose FTW, it was easy) and bingo, IoTaWatt logging is working once again!

Glad you got it working. Docker networking is confusing, and on my list to learn more about. I’ve had a couple of mystery issues that just rebooting fixed, sounds like you just used a bigger hammer. :smiley: